0

Installed Dolphin from the App Store, like that split plane feature. Alas I cannot seem to access mounted SSH devices from my local network. Probably something very obvious?

0

This is due to access permissions. Flatpak installations do not have complete access to your system, so you need to explicitly grant permissions. Fortuntaely, it's not too difficult.

To give any software you've installed from the App Store permission to access a file location, do this:

  1. Open Terminal
  2. Grant permission:
    sudo flatpak override <package_name_here> --filesystem=<path_here>
    
    Note: If you have a path with spaces or special characters, be sure to wrap the <path_here> value like "<path_here>".

Later, if you need to remove access to a location, use the --nofilesystem option to remove permissions:

  1. Open terminal.
  2. Revoke permission:
    sudo flatpak override <package_name_here> --nofilesystem=<path_here>
    

If you would like to know more about the different options that are available for App Store-installed app permissions, you can read about the Flatpak sandbox here.

2
  • Thanks! That did the trick
    – Rodney
    Sep 11 at 5:43
  • Feel free to click the check mark to accept the answer and/or hit the up triangle. Votes help other people with the same question to find answers 👍🏻
    – matigo
    Sep 11 at 7:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.