1

I have been using Elementary OS Odin for about a week. Several days ago I couldn't connect to the internet and pinging a domain name yielded the "Temporary failure in name resolution" error. As per the advice of many people on Stack Exchanging and elsewhere I manually altered /etc/resolv.conf to show:

nameserver 1.1.1.1
nameserver 8.8.8.8

And wrote dns=none under [main] in /etc/NetworkManager/NetworkManager.conf. This solved my problem.

Howeve, when starting my computer yesterday I once again couldn't connect to the internet and pinging a domain name again yielded the same error. The files mentioned above had not been modified in any way and still appeared as I wrote them.


Here are all the additional things I have looked into in the hopes of resolving the error (or at least seeing what would happen):

My datetime is correct.

I am connected to the WiFi network.

All code insystemd/networks.conf is commented out.

nsswitch.conf appears exactly as it does here

I undid the initial actions described in the first section.

I successfully temporarily disabled IPV6 as described here.

I ran the commands from the firewall section of this article.

I added one of Google Public DNS IPV6 addresses to /etc/resolved.conf (while IPV6 was enabled).

Nothing resolved the error. Several times during this process the wireless section of my Network Manager GUI completely disappeared. I could not determine why. Rebooting restored it.

Edits as per matigo's comment

systemd-resolve --status | grep Current yielded:

Current DNS Server: 1.1.1.1
       Current Scopes: DNS
       Current Scopes: DNS
       Current Scopes: none
       Current Scopes: none

ping -c 2 1.1.1.1 yielded:

PING 1.1.1.1 (1.1.1.1)  56(84) bytes of data

--- 1.1.1.1 ping statistics ---
2 packets transmitted, 0 received, 100% packet loss, time 1028ms

dig @1.1.1.1 elementaryos.stackexchange.org yielded:

;<<>> DiG 9.16.1-Ubuntu <<>> @1.1.1.1 elementaryos.stack exchange.com
;(1 server found)
;; global options: +cmd
;; connection timed; no servers could be reached

resolvectl query elementaryos.stack exchange.com yielded:

elementaryos.stack exchange.com: resolve call failed: All attempts to contact name servers of networks failed
4
  • Let's go through the steps to see where the problem is happening. Can you edit your question to include the output of: (1) systemd-resolve --status | grep Current (2) ping -c 2 {the IP address that appears in (1)} (3) dig @{the IP address that appears in (1)} elementaryos.stackexchange.com (4) resolvectl query elementaryos.stackexchange.com. With this information, we can begin to determine where the problem stems from 👍🏻
    – matigo
    Sep 7, 2021 at 0:27
  • I have edited the question to include the information that you asked for. Seems like "resolve call failed" is the key error?
    – LemurLad
    Sep 7, 2021 at 2:28
  • I am not 100% sure this is relevant, but when I run resolvectl status under the global information Current DNS Server: 1.1.1.1, but under the different link headings DNS Servers: ::1. ::1 was the address which NetworkManager.conf was populating /etc/resolv.conf when I first experienced the name resolution error.
    – LemurLad
    Sep 7, 2021 at 15:25
  • 1
    @matigo I only just realized I had to @ you in order for you to be notified of my comment! my mistake. In any case, I resolved the error, see the answer I posted. Messing around with the resolvectl command gave me a hunch it had something to do with the VPN so thank you for that.
    – LemurLad
    Sep 8, 2021 at 2:02

1 Answer 1

0

The error was resolved by turning off the kill switch in Proton VPN. Apparently this is caused by the IPV6 leak interface getting left in place if the system is shut down while the VPN is connected with kill switch on. This will persist until the kill switch is turned off or the VPN disconnected and reconnected. This is a known bug that should be addressed at some point.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.