0

I have just upgraded to Odin, and my bluetooth didn't work (stuck in descovering devices), just as the older version had to install Blueman again to make it work, is it some kind of bug? or something I have to fix regarding my hardware? any help will be appreciated , thanks!

My bluetooth card is Network controller: Intel Corporation Wireless-AC 9560 [Jefferson Peak]

9
  • Add your system specs please.
    – Maccer
    Sep 2 at 9:45
  • my specs lscpu, is this enough?
    – zensir
    Sep 2 at 17:57
  • try with lspci so that we can know what bluetooth card you have.
    – Maccer
    Sep 3 at 23:01
  • OK, sorry about that, here are my lspci specs
    – zensir
    Sep 6 at 11:49
  • Since your hardware is quite recent I recommend installing HWE kernels. They have more updated drivers. sudo apt install --install-recommends linux-generic-hwe-20.04. I can't say for sure this will solve it, but it is worth a try.
    – Maccer
    Sep 6 at 13:54
0

Possible solutions:

1. HWE kernel with updated drivers:

Since your hardware is quite recent I recommend installing HWE kernels. They have more updated drivers. `sudo apt install --install-recommends linux-generic-hwe-20.04.

2. Disabling fastboot if you dualboot with windows

You need to go to your Windows system and then “Control Panel→Hardware and Sound→Power Options→System Settings”. Select “Chooose what the power buttons do” to access the System Settings from the Power Options. Then disable the “Fast Startup” option in “Shutdown Settings”. This will cause Windows to fully shutdown and may solve the issue.

3. Restarting the module

With sudo rmmod btusb && sudo modprobe btusb. If after a reboot the bluetooth module stops working again, it is necessary to enable the systemd service.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.