I installed elementary OS on Virtual Box. My prime OS is Windows 8.1. So after the installation I tried to change the resolution, but the only resolution available was 640x480. I tried to insert Guest addition, but it gives me this error. This Error

  • See my answer in ^ post, exactly answer your Q. =)
    – Ravan
    Nov 7 '15 at 1:51
  • 1
    Yes, thank you ! Very good guide, easy and simple. It worked flawlessly.
    – BlackSova
    Nov 7 '15 at 3:18
  • If worked, I recommend you to close as duplicate = ) @BlackSova
    – Ravan
    Nov 7 '15 at 3:56

Solved this just now on a Mac host in Virtualbox 5.0.8 by in terminal for host: VBoxManage setextradata global GUI/MaxGuestResolution any

and then in terminal for guest: all the steps set out at install-virtualbox-guest-additions-elementary-os.

required some small experience with using the terminal, reading the text to understand what it was telling me to do about installing dependencies and removing unneeded or broken things.

sudo apt-get update


sudo apt-get autoremove

got used a lot, probably more than necessary.

Once I did that, screen sizes are available.

Then I went to the Files window and tried to change from icons to list and everything froze and I had to power cycle the VM, but it seems to still work after restarting it.


Not the answer you're looking for? Browse other questions tagged or ask your own question.