0

I have eOS 6 and is trying to install the virt-view software. The apt install virt-view command failed with the following dependencies error:

$ apt install virt-viewer

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 elementary-tweaks : Depends: libgranite5 (>= 0.2.0) but it is not going to be installed
 virt-viewer : Depends: libgovirt2 (>= 0.3.4) but it is not going to be installed
               Depends: libgtk-vnc-2.0-0 (>= 0.4.1) but it is not going to be installed
               Depends: libspice-client-glib-2.0-8 (>= 0.35) but it is not going to be installed
               Depends: libspice-client-gtk-3.0-5 (>= 0.32) but it is not going to be installed
               Depends: libvirt-glib-1.0-0 (>= 0.1.8) but it is not going to be installed
               Depends: libvirt0 (>= 1.2.8~rc2) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

I tried apt --fix-broken install but that didn't fix the issue. Any idea how to fix this?

1 Answer 1

0

I can help you with the elementary-tweaks issue, it won't work on Odin, you'll have to install pantheon-tweaks. Here you can find how to install it: https://github.com/pantheon-tweaks/pantheon-tweaks

1
  • Thank you. The pantheon-tweaks package works.
    – Henry
    Aug 31, 2021 at 13:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.