0

I have tried latest elementary OS using a live test environment without installation on harddrive.

I have found that e OS comes without support for my WLAN USB-Stick, so I had to manually download required *.deb package "borrowed" from Kali linux (working on ubuntu also) before that and during live session install this via dpkg -i from a memory USB-Stick.

Unfortunately, it turned out that these packages want to install a module which is compiled for current (or all) kernels present on system. This did not work first, because eOS also comes without DKMS to compile modules, and, even worse, without kernel-header-packages to compile anything. So I had to give in and use an older WLAN-stick to get these missing packages on my live eOS as well, but still no success, because modprobe would load the module for my new WLAN Stick but not use it, let alone show available WLAN networks around.

What should I do to get full module support for current kernel in eOS live installation and how should I activate this WLAN stick? I would like to make sure all my WLAN-HW is correctly working prior to installation.

It is a RTL8812AU USB-stick.

Would an installed eOS have DKMS + kernel header packages installed out of the box?

Thanks a lot for your support.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.