0

The installation process crashes after selecting installation USB from the boot menu and getting past the elementary OS logo screen by waiting the 10 seconds or pressing enter.

Motherboard manufacturer logo quickly flashes and then I get the following error every time:

[    1.024924] gpio gpiochip2: (gpio_aaeon): tried to insert a GPIO chop with zero lines
[    1.024933] gpiochip_add_data_with_key: GPIOs 0..-1 (gpio_aaeon) failed to register, -22

And a frozen prompt, only option from there is a forced restart.

I've tried replacing EFI with the one from Ubuntu image, in case this had something to do with the https://github.com/elementary/triage/issues/74 issue, but with little success. I've also tried different USB drives and image flashing methods. Secure boot is disabled as far as I am aware (ASUS calls it "other os" mode in BIOS, I believe). Also tried to boot with all TPM / Trusted Computing features off, in case it had any effect.

I have successfully installed eOS on multiple PCs before, so I do know the process somewhat and have not had such issues previously.

System Specs:

  • ASUS PRIME B550-PLUS
  • Ryzen 3600
  • 32GB RAM
  • 6700 XT
  • Intel 660p 2TB Nvme SSD

2 Kingston installation flash drives, tried both MBR and GPT. Worth noting that this is the PC I am currently writing this on, and that eOS would be installed to an empty partition for dual boot along Windows.

4
  • Can you edit your question to include the brand and model of the computer you’re installing this on? This will make it easier to check for hardware compatibility issues 👍🏻
    – matigo
    Aug 20 at 12:35
  • Sure thing, system specs added.
    – a2m
    Aug 20 at 12:53
  • Elementary OS 6 ships with the 5.8.x kernel, and your motherboard — based on reports from people on various geek sites — will require 5.9.16 at the very least to work effectively. You may need to wait until eOS 6 is on a point release 🤐
    – matigo
    Aug 20 at 13:24
  • Oh, alright. Searching around I did find something about the kernel possibly being incompatible, but wasn't quite sure since I have little to no experience dealing with kernel issues 😅 Thanks a lot, I'll keep an eye on eOS development then!
    – a2m
    Aug 20 at 14:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.