I currently duel boot another LInux Distro with Windows 10. I want to replace the existing Linux distro with elementary OS 6. Elementary OS doesn't appear to see the duel boot setup. What's the best way to install elementary OS over the existing Linux distro and maintain my Windows 10 duel boot. Below is a screenshot of my current partitions.

enter image description here

1 Answer 1


TL;DR Backup your important files, then install the OS to your custom partitions. If the elementary OS install wizard cannot configure the boot loader correctly, try installing and running Boot-Repair from a live boot session.

From your screenshot, it looks like the former Linux install was likely on /dev/sda6, and your PC was previously prepared with a UEFI partition, but it might not be in use right now (it doesn't have the 'boot' flag toggled.)

Before proceeding, make sure that you back up anything important on your hard drive, and confirm whether or not your device supports UEFI and has it enabled. Also, please note that since you're using MBR with an extended partition, I'm not sure whether any of the following I have to say applies or not. As of late, I always use GPT where I can instead of MBR.

When booting from the elementary OS 6 disc, I think you'll want to perform a custom disk install and target /dev/sda6 at the / mount point. If you don't target a specific partition for /boot /swap or /home, then I believe it'll just install everything into one simple partition just fine.

/dev/sda5 can remain mounted to /boot/efi, but you may need to toggle the 'boot' flag on it before starting through the elementary OS installer.

For my own Dell laptop reinstall from elementary OS 5 to 6—also a dual-boot system with Windows 10—I custom configured /boot, /, /home, and /swap partitions and ensure that I linked them appropriately during the installation wizard.

The installer appeared to finish copying over all of the OS contents to the okay, but it failed to write the boot loader correctly. I had UEFI enabled and Safe Boot disabled. Post OS install and a reboot confirming that the boot loader didn't write correctly, I ran Boot-Repair from another live-boot disk, fixed it up automatically, and rebooted, and now everything works fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.