0

I've confirmed this behavior installing from both the final Odin .iso, and upgrading via meisenzahl's upgrade script:

With nvidia-340 installed on my MBP5,3 (with an Nvidia GeForce 9400M & a GeForce 9600M GT), the graphical login screen gets a black (not grey) background and lacks any of the network/shutdown/restart icons in the upper right. When one logs in with user/pass, the screen goes blank, sometimes switching to a text-only display with one to three lines that are generally to quick to catch, and then cycles back to the black-backgrounded graphical login screen. It does not go to a desktop.

Ctrl-alt-F3'ing to log into a CLI shows that permissions on .Xauthority are fine, and reconfiguring or reinstalling lightdm has no effect on the above behavior. Removing nvidia-340 & its associated files (whether or not one sudo apt autoremoves at the same time) does allow one to log in to the GUI, but apps such as Firefox get hung trying to render any new pages, for example (I guess they need that graphics acceleration they're not getting). Epiphany seems to work fine (I'm composing this on it). Nvidia-340 and its OpenCL component both list in fact to be 340, and correctly for Ubuntu 20.04. Nvidia-settings, interestingly, seems to be 470 (for Ubuntu 20.04).

Also, when trying to reinstall Nvidia-340 from either the AppCenter or from Terminal, the install script exits with an error 10, and tells me that nvidia is broken or incompletely installed. Neither dpkg-reconfigure or reinstalling fix this, though remove and remove --purge (along with sudo apt autoremove) work fine to continue to use the GUI un-accelerated.

Is this something a new/tweaked version of lightdm might address, to play nice with Nvidia-340, or are we stuck waiting (possibly forever) for Nvidia to update/tweak Nvidia-340?

Lastly, before you tell me to upgrade firmware, I'm running the latest that the fruit company bothered to make for their MBP5,3 way back in 2009. I've got elementary installed under OpenCore with "Custom" instead of "Create" in UpdateSMBIOSMode & "true" rather than "false" in CustomSMBIOSGuid, so elementary has direct access to the firmware of the system it's running on, not the firmware of a newer model that OpenCore emulates for macOS. That means elementary's running on the bare metal of the system it would be, if it booted up on its own under grub. This means that while nvidia-340 under Hera (for Ubuntu 18.04) worked fine, nvidia-340 or how it interfaces with lightdm in Odin (for Ubuntu 20.04) is currently broken, at least on my MBP5,3 with abysmally old & non-upgradable firmware.

Any suggestions or plan on a roadmap to address this? If I go back to Hera, how long with my system enjoy support?

Thanks!

2
  • UPDATE: Adding the following PPA with legacy Nvidia drivers appears to have worked. A PPA is not my favorite solution in terms of security, but it works for Firefox rendering (which I assume is hardware-accelerated) and I'm back up to the usability level I was at in Hera, with otherwise the latest of Odin packages, look & feel. So, cool, I guess. Hopefully there can be a more official fix from elementary soon. launchpad.net/~kelebek333/+archive/ubuntu/nvidia-legacy
    – juanejot
    Aug 17 at 1:10
  • UPDATE 2: They updated the greeter today (8/17/2021), but apparently for some unrelated issue. When I switched back to elementary's mainline version of nvidia-340, it had some of the same install errors that had occurred on upon original installation, and the greeter was still black-backgrounded with no icons in the upper right, looped & didn't let me through. Switching back to the above PPA's nvidia-legacy version worked again, luckily.
    – juanejot
    Aug 17 at 19:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.