I Currently has Fedora 23 running on a Macbook Pro 2009. Works great, but I miss elementary OS, which I use daily on my tower. I used dd to create a bootable USB of Ubuntu 15.04 and when I restart the mac and hold down the option key, the Ubuntu USB is recognized and I can boot into Ubuntu from the USB.

I did the same dd command with the elementary OS freya .iso:

sudo dd if=elementaryos-stable-0.3.1-amd64.20150903.iso of=/dev/sdb bs=1M

after than finished, I rebooted and held down the option key and only see my Fedora drive pop up. I then tried a different USB as well as an external USB HDD, all of which never show up when holding down the option key on reboot.

Also note, I tried these elementary USBs on a Windows box I have and all USBs showed up, and were able to boot correctly into elementary OS from the USBs.

So my question is, is there a way to get a macbook to boot from USB into elementary OS freya?

Also, does anyone know what Ubuntu's ISO has that allows it to be recognized on mac hardware that other Linux distros might not have?

closed as off-topic by Hasan Oct 22 at 3:19

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "The Question is about a release or feature that has been significantly updated, to the point at which upgrading fixes the issue or answers the question." – Hasan
If this question can be reworded to fit the rules in the help center, please edit the question.


You can use Rufus or Etcher for create a new bootable usb you can go Fedora and install Etcher and create a new bootable usb.

Not the answer you're looking for? Browse other questions tagged or ask your own question.