0

When I logout and log back in the sound seems to work but the sound icon itself says that it cannot detect any speaker and I cannot control the sound no more.

I suspect that the issue is that pulseaudio does not start when you log back in, only when you reboot; thus, this issue only appears in this specific situation.

Solutions I tried:

  1. Tried to $ sudo systemctl unmask pulseaudio-enable-autospawn.service but it did not work and the service remained masked.
  2. Tried $ sudo mv /usr/lib/systemd/system/pulseaudio-enable-autospawn.service /usr/lib/systemd/system/pulseaudio-enable-autospawn.service.old and $ systemctl list-unit-files | grep pulse returned nothing but the issue remained the same.
  3. Tried to remove ./.config/.pulse folder and $ sudo apt install --reinstall pulseaudio but it the issue remained the same
  4. Tried $ pulseaudio, it only made the icon appear as if the speakers is working but it is actually a total malfunctioning icon that does not control anything.

should i reinstall my system?

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.