3

I installed elementary OS 6.0 Odin (final release 2021-08-10).

I was finally able to get FlatPak apps to install. However, none use the elementary OS Dark Theme. I checked FlatPak and the elementary theme is installed. How do you get Odin to use the Dark Theme system wide for all FlatPak apps?

1

I also needed to install a dark theme to flatpak with

flatpak install flathub org.gtk.Gtk3theme.Adwaita-dark

Then using

flatpak list 

to get the application ID... Then the following command to apply the theme to the application ID... For example with LibreOffice

flatpak override --user --env=GTK_THEME=Adwaita-dark org.libreoffice.LibreOffice

That command worked great in Hera, but it seems to be hit or miss in Odin. It will hold for a while... even occasionally after a reboot, but ultimately it seems to lose the setting and default back to the flatpaks "light" setting.

Adding GTK_THEME=Adwaita-dark as an Environment Variable in Flatseal seems to yeild the same results. Works for a while but in Odin, it seems to disappear. In Hera it appears permanent.

0

You can force to use dark stylesheet using Pantheon Tweaks which will create new local settings under ~/.config/gtk-3.0/settings.ini with content below.

[Settings]
gtk-application-prefer-dark-theme=1
0

Here's another approach:

"Uniform theme and fonts for Qt apps in GTK environments" provided by the EndeavourOS-guys: Instead of the the given arch-linux install cmd ('pacman -S pkg-name') you have to replace it with your normal install cmd ('apt install pkg-name'), and then follow the given instructions for user-space-setup (quickest).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.