0

When flatpak apps are installed in elementary OS 6 Odin, they don't seem to have access to any directories outside of their allowed / sandboxed folders. For example, they can't access the real subfolders of /var/.

This has supposedly been answered before in this elementary OS StackExchange and on the Ubuntu StackExchange, however these don't seem to work in elementary OS 6. They recommend running:

flatpak override package_name_here --filesystem=path_here

And we can use flatpak list to see all our installed flatpak apps.

For Atom for example, I've tried the following, however this doesn't have any effect, even after restart.

sudo flatpak override io.atom.Atom --filesystem=host

The same applies to other flatpak apps I've tried this with. Is there something else to try?


Update: According to the official Flatpak docs, the /var directory is specifically blacklisted (when using the host setting). So perhaps it's just not possible to give this permission...?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.