0

Back in elementary 5.1, my Lenovo Ideapad 3 15IIL05 required the "pci=nocrs" boot/kernel parameter on the GRUB_CMDLINE_LINUX_DEFAULT line in the /etc/default/grub file to make my touchpad function. For some reason, in elementary OS 6, this no longer works. The steps I've followed to try to remedy this are:

  1. Use sudo nano /etc/default/grub to add the pci=nocrs parameter to the GRUB_CMDLINE_LINUX_DEFAULT line. Save and exit.
  2. Run sudo update-grub. It appears to run successfully.
  3. Reboot, try to use touchpad without success :/

I've double checked this process, which worked on the last elementary OS version, and I've gotten the same unfortunate results.

The next thing I checked was the actual grub.cfg file in /boot/grub/grub.cfg and to make sure the boot param was actually being updated by the update command. It appeared to not add pci=nocrs anywhere, surprisingly, and when I tried to manually add it to the correct line (usually a very bad idea, dont do this!!) and rebooted, I still didn't get any results, aside from losing wifi card access. Removing the param restored network though.

Is there anything else I should try? Is there a known issue with changing grub boot params right now that I haven't found out about? If you know anything about this issue I'd appreciate the help, thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.