1

I just installed elementary OS 0.3.1 Freya (64-bit). I have installed the Nvidia driver 352.55. I used this guide to help me install the Nvidia drivers. Afterwards I have installed Steam using

sudo apt-get install steam

Everything seems fine so far. However when I try to start Steam I receive the following error:

ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
[2015-11-05 19:35:42] Startup - updater built Nov 25 2013 18:07:05
libGL: screen 0 does not appear to be DRI2 capable
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/swrast_dri.so
libGL: Can't open configuration file /home/mathyn/.drirc: No such file or directory.
libGL: Can't open configuration file /home/mathyn/.drirc: No such file or directory.
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)

So far my Google searches have not yielded a solution. Does anyone know what causes this error and how to fix this?

2

Did you do a reboot after installing via sudo apt-get install steam ? I found I after I installed steam via apt-get, I had to do a reboot, then open a terminal and type steam . The client would open and begin updating for a couple of minutes. After updates were installed, I rebooted again and was able to click the icon to launch Steam. All attempts to launch steam prior to reboot and running steam from the command line gave me errors.

  • Just gave it a try. Sadly it did not work for me. – Mathyn Nov 6 '15 at 18:49
  • @Mathyn Dang. The next thing I would try would be completely deleting steam by doing: sudo apt-get purge steam, then try to reinstall steam and reboot and run steam from the command line like my answer says. If that still doesn't work, I'll have to dig deeper. – vim_usr Nov 6 '15 at 19:48
  • I just found a solution. I removed Steam and used the Steam install from the official website. This worked for me. Thanks for the help! – Mathyn Nov 6 '15 at 20:58
1

I found a solution. I uninstalled Steam and then used the download at the official Steam website to install. This fixed my problem.

Maybe the apt-get package is outdated?

  • 1
    That makes me wonder, did you run: sudo apt-get update prior to installing steam via apt-get install steam ? If not, that may have been the issue. At any rate, glad it worked out for you in the end. – vim_usr Nov 6 '15 at 21:01
  • I might have forgotten it, I'm not sure. I could give it another try but now that everything works I'd rather not touch it ;) – Mathyn Nov 6 '15 at 21:09
  • Yeah--don't fix what ain't broken lol. Enjoy! – vim_usr Nov 6 '15 at 21:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.