0

Installation media refuses to boot in UEFI on my desktop core i7 4790 with asus MAXIMUS VII RANGER Z97 chipset motherboard bios v3503. I downloaded and checked Elementary OS 6 image several times, I tried to burn it with Etcher as recommended or Rufus, in MBR or GPT format. The created key refuses to start in UEFI mode. No matter if the secure boot is activated or not I always get the following error message : "Invalid image Failed to read header : Unsupported Failed to load image : Unsupported start_image() returned Unsupported"

I must specify that I never had this kind of problem before on this PC and that I installed several distributions in UEFI without encountering this error including ubuntu 20.04 LTS.

The only solution I found to boot on the installation key is to activate CSM (compatibility support module) in legacy mode in the bios boot options. But in this case impossible to install Elementary os in UEFI mode ...

Weird the same install key works perfectly on my other more recent desktop.

1
  • Where do you see that error? What happens if you wait for a while? Does it finally boot the installation? Do you have any other OS installed in this disk? Can you still boot it ?
    – Maccer
    Aug 12 at 9:30
1

I hope the folks at Elementary get a new ISO out soon! Why they are so slow to respond on both Facebook and other forums is not good. They need to get a new ISO out ASAP.

Imagine your band just released a new album with all kinds of promo and press releases only to find out that all the tracks are garbled when downloaded from iTunes or Amazon.

See: https://github.com/elementary/triage/issues/74?fbclid=IwAR2YEuN2U9vgW3LNDk5WwENE-UD_887EaVwJZAcy1SzOjuj9OSWMJnVr3ow

https://bugs.launchpad.net/ubuntu/+source/shim/+bug/1937115

0
0

It happens immediately after the initialization when the installation key tries to boot up in UEFI mode (both CSM & SECURE BOOT disabled in boot bios settings). No need to wait long it opens the bios setup screen after a few seconds.

I don't have any other OS installed. The only drive plugged is an empty SSD without any partition on it waiting to receive the system.

0

I gave a try to Workaround 2 from https://github.com/elementary/triage/issues/74?fbclid=IwAR2YEuN2U9vgW3LNDk5WwENE-UD_887EaVwJZAcy1SzOjuj9OSWMJnVr3ow and it worked nice for me THX !

"If you are unable to disable secure boot, or the previous workaround doesn't work, the next best option is to download an Ubuntu 20.04.2 iso and copy the EFI folder from it to the elementary media (overwriting the original EFI files).

Whether this is possible depends on how the iso has been written to the USB media as sometimes it is left in a read-only state. If you are able, you can manually format the USB stick as FAT32 with a GPT partition table, then copy the files to it from within the elementary iso. Then you should be able to replace the EFI folder with an Ubuntu one afterwards.

Using this workaround should allow secure boot to function correctly."

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.