5

Why is my notebook very hot? I installed the driver for Nvidia, but nothing changed. Ubuntu has a temperature of 40-50C with the driver and 70-80C without the driver. Terminal:

sergey@sergey-Aspire-5750G:~$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +82.0°C  (high = +86.0°C, crit = +100.0°C)
Core 0:         +82.0°C  (high = +86.0°C, crit = +100.0°C)
Core 1:         +81.0°C  (high = +86.0°C, crit = +100.0°C)
  • might be driver problem, have you tried removing drivers? – Ravan Nov 5 '15 at 13:21
  • yes, I installed different driver. installed and removed it. – Sergey Molyak Nov 5 '15 at 13:31
  • have you tried reboot? – Ravan Nov 5 '15 at 13:32
  • Is it dual boot? The temperature problem is with only elementary OS? – Ravan Nov 5 '15 at 13:37
  • yes, eOS only.. – Sergey Molyak Nov 5 '15 at 13:53
3

First, update your system:

sudo apt-get update && sudo apt-get upgrade

Then we are going to install some packages that work really well with this issues. But first we need to remove laptop-mode-tools (if you didn't install it just go to the next step):

sudo apt-get remove laptop-mode-tools

Now, we have to install TLP:

sudo add-apt-repository ppa:linrunner/tlp && sudo apt-get update && sudo apt-get install tlp tlp-rdw

And also install thermald:

sudo apt-get install thermald

Finally, reboot your system and you are done!

Note: I don't know what driver you've installed. If this doesn't work, the easy way to solve it would be reinstalling elementary OS and then installing again TLP and thermald.



TLP

Thermald

  • what temperature is considered normal? – Sergey Molyak Nov 7 '15 at 13:37
  • For example, in a warm day with light use (just using the internet or writing a mail) the fan shouldn't spin really fast. – Maccer Nov 7 '15 at 13:44
  • no, what temperature? I have 15C in the room and -1C outside :) – Sergey Molyak Nov 7 '15 at 13:48
  • Men it depends on your laptop. But I'd consider 50-60 ºC a normal temperature. The lower the better, of course. – Maccer Nov 7 '15 at 13:50
  • @Ravan I didn't write Sudo. I don't know where you found that... – Maccer Dec 12 '15 at 13:53
0

One other thing to note here is that if you are using Nvidia Graphics card with Optimus Technology and you are running official drivers. If you go to Nvidia X Server Settings, under PRIME profiles, you can select the Power Saving Mode which disables your Nvidia card and uses the motherboard's graphic card instead. This is essentially what Bumblebee does (kind of). This should also prolong your battery life. One thing to be mindful of here is that this could disable the graphics port connected to the card. For my laptop, this was the HDMI port; thankfully, the mini-display port is connected to the Intel Graphics card.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.