1

Downloaded the ISO file for eOS 6 and tried to test-run in VirtuaBox.

Unfortunately, the Elementary installer window is out of bounds and the usual "press ALT and drag the window with the mouse" doesn't seem to work in Elementary. This makes it unable to move forward in the install process.

enter image description here

3
  • Hello. I think this issue is more related to VirtualBox than elementaryOS. Anyway, could you maybe try to maximize the window or change the resolution of your VirtualBox instance?
    – Maccer
    Aug 11 at 8:28
  • Maximizing the VirtualBox window doesn't change the virtual screen resolution unless the guest OS supports it. At the install time, Elementary OS doesn't. VirtualBox doesn't allow me to force a different resolution.
    – pascalbrax
    Aug 11 at 9:00
0

I had the same problem and was able to solve it by switching the Virtualbox Graphics Controller from VMSVGA to VBoxSVGA in the display settings of Virtualbox (my Virtualbox version is 6.0.4. - host is MacOS Mojave). Elementary OS 6 looks great in my test run!

1
  • Thank you. Switching to VBoxSVGA helped me increase the virtual screen resolution.
    – pascalbrax
    Aug 11 at 12:21
2

This worked for me for the installation issue:

Boot the installer in EFI mode not legacy-BIOS mode.

It's Settings->System->Enable EFI (special OSes only).

https://stackoverflow.com/questions/57115746/virtualbox-screen-resolution-too-small-during-installation

0

This is something that happens on all Distros based on my experience. Virtualbox seems to have a default width and height that cannot be changed except when you install the virtualbox Guest additions, at least when opting for VMSVGA with 3d acceleration on.

This is also visible after installing the Guest additions, when you have the windows maximized, and you reach the login screen. that one is also in a very low resolution but the quantity of information is much less.

Screen resizing only happens when Pantheon (or any other DE) is fully loaded.

2
  • >> This is something that happens on all Distros based on my experience << True, but other distros have a different installer that accomodates lower resolutions. Tested right now with Linux Mint installer and I was able to see the whole installation window.
    – pascalbrax
    Aug 11 at 12:14
  • Fair enough... I have been playing around with ubuntu, and pop_os and fedora 34 lately and all had the same issue... so I thought it was universal. Aug 11 at 14:05
0

I have the same issue with the cutoff window as the OP, except I am installing to Windows 10 host. I had an issue with the installation of Elementary OS 6 for the same reason. The right side and bottom portion of the installer screens were cutoff. That area of the screen has buttons for back, submit, cancel.

I resolved this by making to selection to erase/complete install, then using the tab key twice followed by the enter key. Apparently this sequence of keystrokes allowed me to initiate the full installation script successfully.

-2

Use Auto scale guest OS in Virtualbox. Problem solved

1
  • This is incorrect. There were a number of issues with the earlier ISOs in VirtualBox. Fortunately, these have been mostly resolved when running non-scaled displays.
    – matigo
    Sep 28 at 6:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.