2

I bought a used Gigabyte Windforce R9 290 OC graphics card off eBay recently, and was wondering whether it in fact was broken or I am doing something wrong. I am not able to seem to get it working.

If I have the graphics card in the computer, the installer doesn't seem to load (black screen), so I take it out to install. Then I make sure I update & upgrade everything. I then tried rebooting with the GPU installed but again a black screen. I tried downloading the AMD proprietary drivers from their site, tried both their .deb & .run files and neither actually installed (likely as I didn't have the graphics card installed). So I booted with 'nomodeset' to try and get in to install drivers. This worked, although at some tiny resolution and random green flashing (like a semi-transparent layer of green). I installed the AMD for Linux (.run) driver fine, so disabled nomodeset and rebooted. Black screen again. I re-enabled nomodeset, this time it booted at the right resolution (1920x1080), except there were green flashes, especially on animating windows (haven't tried any games yet).

I tried installing Windows 10 on the computer without the graphics card and it worked fine, so installed the graphics card but then ended up with a low (1024*768) resolution, using the default Microsoft drivers. I managed to install the catalyst drivers and it work fine, but with green flashes again except much rarer (once every minute, not every time I resize a window).

My specs are:

  • i7-4790k
  • Gigabyte Windforce R9 290 OC
  • Samsung 850 EVO 500GB
  • 16GB HyperX DDR3
  • EVGA 600W PSU

Thanks in advance!

  • In the end none of the solutions both here, on reddit and after contacting another guy worked :/ so I just ended up sending back the card. – domdomegg Nov 9 '15 at 17:30
1

I am using an R9 270 by Sapphire, so this may or may not apply to you. I installed the driver by using 'additional drivers'. I typed 'drivers' in the Applications search box and 'additional drivers' popped up. It found fglrx AMD/ATI proprietary drivers, clicked install, then rebooted. Everything is working great. If this doesn't work you you (like you get black screen upon bootup,) you can try pressing Ctrl+Alt+F1 to get to a terminal then try sudo apt-get install fglrx. then sudo reboot.

(If you ever use Ctrl+Alt+F1 to get to a terminal and need to get back to a GUI (assuming your GUI is working properly) you can press Alt+F7)

-2

I think all you should need to do is add the ATI repository and then run sudo apt-get update

  • 2
    How would I add the ATI repo? I can't find a link anywhere. Sorry if I'm being dumb, but I'm new to Linux :) – domdomegg Nov 5 '15 at 22:50
  • memoryleakx has the hot tips. Using his reference because I'm used to doing it through openSUSE's YaST tool. First: sudo add-apt-repository ppa:xorg-edgers/ppa then sudo apt-get update && sudo apt-get dist-upgrade then sudo apt-get install fglrx-installer i have no idea how to make line breaks in minimarkdown – StackAttack Nov 7 '15 at 0:52
  • Oh and reboot after all the install and it should work – StackAttack Nov 7 '15 at 1:15
  • 1
    @StackAttack Can you please edit your answer to include these more verbose instructions? – Daniel Foré Nov 8 '15 at 0:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.