0

After doing a fresh install of Odin, whole disk, on a 2015 13” MacBook Pro the grub menu is showing 1 row of pixels of output.

Seemingly, this error also prevented me from being able to use the Encrypted Disk functionality available during OS install, as I am now realizing the reason the system seemed to hang after reboot was that the prompt for the password was invisible due to this same error.

However, I then reinstalled without encryption and am now facing this grub issue. Of course, if I wait the 10 seconds it will just boot normally but I cannot choose any grub settings.

grub output showing 1 row of pixel

I tried modifying the grub file like so:

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLEU=menu
GRB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="earlyprintk=vga"

This didn't work so I tried:

GRUB_GFXMODE=640x480   

And that didn't work so I tried:

GRUB_TERMINAL=console
0

I resolved this by installing boot-repair and using it to disable Secure Boot, which also went ahead and reinstalled grub in the course of disabling that option. Now regular grub things/settings are working. Leaving this unanswered in case someone knows why this happened, as I still believe this is related to not being prompted for disk encryption password after installing elementaryOS with disk encryption.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.