2

i'm trying to install Elementary OS 6, and the Live USB refuses to boot. Everything is normal, i downloaded the image and flashed it with Balena Etcher, and then, after trying to boot it, it gives this error : enter image description here

This is kinda unusual since Eos 5.1 booted normally without problems ( Oh, and also, Here are my specs : ) CPU: Intel i3-6006U (4) @ 2.000GHz GPU: Intel HD Graphics 520 Memory: 4GB Host: Inspiron 15-3567

1
  • Same issue here with a Dell latitude 7450 - adding the boot option fixed it. Many thanks for posting.
    – Mike
    Aug 11 at 6:58
2

I had the same error while being in legacy mode. My fix was to change the BIOS to read a different file than its default in the folder /efi/boot on the usb-stick. To do that I had to create a new boot option as depicted on the photo.

enter image description hereMy laptop a is a Dell Inspiron 3583.

1

I was able to fix this by inserting the USB drive (with the elementary iso) into another Linux machine running on it and typing the following :

efibootmgr --create --label Elementary --disk /dev/sda1 --loader "\EFI\boot\grubx64.efi"

This is assuming the USB is showing up as sda1.

1
  • Nice way to add an EFI loader to the disk.
    – ranu
    Aug 11 at 17:34
0

I am experiencing the same problem on a Dell Optiplex 2090 desktop. I think the provided disk image doesn't have proper support for UEFI and/or secure boot.

To make it boot, I pressed F2 while the system was starting to enter BIOS settings. From there I enabled "Legacy boot" instead of UEFI.

After that, I am able to boot into the installer. Please be aware that if you're dual-booting, changing this setting could prevent you from booting another OS.

0

This is a known problem and is being tracked here: https://github.com/elementary/triage/issues/74

There's a workaround:

Downloading an Ubuntu 20.04.2 iso and copying the EFI folder from it to the elementary media (overwriting the original EFI files) seems to work as a workaround.

I have a Dell Inspiron 15 3583 and I am also affected by this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.