0

To start, I am an absolute beginner in Linux. I'll try to be as detailed as possible. Any help would be greatly appreciated!

I have a MacBook Pro 2010 13" with an SSD and an HDD. I have installed Elementary OS Hera 5.1. on a seperate partition on the HDD (not wanting to risk my boot-SSD of merely trying out Linux) from an installation USB. The installation works fine, I think, seeing that the first boot out of the installation is no problem. The first thing I did was install updates and drivers to get regular things working, like Wifi for example. I also noticed that it didn't recognise my external monitor at all, which it did during the installation.

After that, I closed the lid of the MacBook, and when I opened it again, the screen stayed black. I did a force-reboot with the power button on the MacBook and from then it never booted again. During boot I see the ElementaryOS logo for a bit before the screen turns off completely, with a flash. I'd like to point out that it isn't just an empty screen that I'm seeing, the screen is actually off. The hard drive is spinning, as if it is doing something, but even after hours of waiting, nothing is happening.

I tried researching and tried several solutions, like going into Grub and trying the various advanced boot options, I tried 'nomodeset', I tried formatting and reinstalling, all to no avail.

I would love to try out Elementary to see if I would want to take the step to Linux to give my MacBook a new life, so if anyone has any idea what is happening or what I can try, I would love to hear it!

0

I am not sure that the bootloader is pointing to Elemntary OS because you have installed both OS on different hard drivers. You said that you have booted once and now it does not boot at all which is kind of odd to me and i do not know why. but i advice you to install any OS in general on the SSD and keep them on the same drive, this will make things much faster and reliable.

to better debug the issue, can you try pressing ctrl+alt+F1, it will give you a black screen (terminal), if it does give you that window, then your issue will be the display only.

2
  • Thanks for your reply! I would think that the bootloader is pointing to Elementary, or the standard Apple bootloader at least. Because at bootup I press the alt/option-key, it shows me the bootloader, I select Elementary instead of MacOS and then I shortly see the Elementary Logo before the screen turns off. Or are you talking about a different bootloader and are there multiple to think about..? I will definitely try your solutions pressing ctrl+alt+f1, and installing it on my SSD. Aug 3 at 8:23
  • @DorusvandenBoomen if logo appears means it is booting, please try what i asked and let me know. Aug 4 at 14:58
0

@Omar Shawky

So, here's my update:

By now, I've installed eOS on my SSD, which makes everything faster, but now more functional in the black screen problem. I have by now figured out that it has to do with the Nvidia-340 driver. Everything works until I install that. I have no clue if I need it, or can simply use eOS without this driver. I have the 'nouveau' driver active now, which seems ok?

Every time I do a new install, which I have done a lot of times now, there seems to be a new problem. Updates won't install, or it hangs, or it is very sluggish... Particularly the last thing bugs me, because I was hoping that using Linux would breathe some new life in my old MacBook. Is it always this problematic, or is this just me..?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.