1

I have a Huawei Matebook D15 laptop. Precise model is BOD-WWX9-PCB. It has latest 11th gen Intel Core i5-1135G7 CPU which comes with Intel Iris Xe graphics.

Main problem is - when I tried live-usb to check if necessary software (VMware Horizon client) for my job is working correctly, I connected to Host server and instead of seeing working environment I saw black screen.

I am not sure what can be the exact reason, but I am sure for the most part it's not VMware problem, because both Pop_OS! 21.04 and Fedora 34 live-usb worked with VMWare Horizon out of the box.

So what should I do? Should I try installing 5.1.7 and manually updating the kernel to latest or hope that 5.8 (or whatever it is) is elementary OS 6 will support latest intel graphics?

Any suggestions are greatly appreciated.

0

pop os uses the 5.11 kernel, fedora 34 kernel 5.12. Try a manual update. i did it for my dell to 5.14 and updated manually all missing firmware i915. firmware package https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/

3
  • So my to-do list is following: - install elementary OS 5.1.7 with kernel 5.4 - manually update it to 5.12-5.14 - install i915 drivers? Thanks! I will try it as soon as I get back to my laptop Jul 20 at 18:16
  • Yes when you will update the kernel (update-initramfs -u -k all) it will show up a list a problem missing /lib/firmware/i915/name_of_the_lib.bin so you have to download them and copy them in the root folder /lib/firmware/i915/lib.bin with the terminal with sudo cp ~/Downloads/*.bin /lib/firmware/i915/ This is what I did from this site with only the ones I missed. If you have the complete folder, you open a terminal in the folder you downloaded and run the same command to copy them. my elementary os hera is running with this kernel now that I am writing to you Linux 5.14.0-051400rc2-generic Jul 21 at 0:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.