0

I installed Elementary OS on my HP Pavillon 15 with i7-1165G7 and Nvidia MX450 and it won't boot up after installation. I get an error on the black screen saying something like rtw_pci: failed to wait firmware completion..

If I try to boot in recovery mode it works (pretty bad though, with no Wi-Fi, no touchpad). So in recovery mode I tried do install all the software updates from the App Center. Nothing changed.

Then I tried to install the nvidia driver from the App Center and after that it won't boot even in recovery mode showing black screen and ticking cursor.

I tried to install several times, with and without internet connection.

Any suggestion? Thank you.

New contributor
Valerio Costantino is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
0

Maybe this is a graphics card problem, when installing Elementary OS did you select to install proprietary drivers?

When you use Nvidia graphics it is advised to do so, to install such drivers during the installation just select the box that says

Install third-party software for graphics and WI-FI hardware and additional media formats

Your Answer

Valerio Costantino is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.