1

it seems like my network device is not supported on kernels below 5.11 is there a way to update the kernel from a disk on key or something since my internet works on the windows 11 I dual boot. Thanks

0

Probably the "easiest" way to do this is to use the Ubuntu mainline kernel PPA, but download the .deb files individually. If you want to download kernels for 5.11.20 go here:

You'll find a bunch of .deb files there, the ones you need are these files:

-rw-r--r-- 1 root root 2.6M Jun 15 09:31 linux-headers-5.11.0-20-generic_5.11.0-20.21+21.10.1_amd64.deb
-rw-r--r-- 1 root root  12M Jun 15 09:30 linux-image-unsigned-5.11.0-20-generic_5.11.0-20.21+21.10.1_amd64.deb
-rw-r--r-- 1 root root  18M Jun 15 09:30 linux-modules-5.11.0-20-generic_5.11.0-20.21+21.10.1_amd64.deb
-rw-r--r-- 1 root root  48M Jun 15 09:31 linux-modules-extra-5.11.0-20-generic_5.11.0-20.21+21.10.1_amd64.deb

Take note that these are the -generic versions and not the -lowlatency versions. Open a terminal and cd into the directory where you downloaded the .deb files and execute these commands in this order:

sudo dpkg -i linux-image-*
sudo dpkg -i linux-modules-*
sudo dpkg -i linux-headers-*

(Note if you try to install things in a different order they will fail)

Once this is done you can now issue a sudo reboot and once the reboot is complete verify that your kernel is updated by running:

uname -ra

Which should yield the result:

Linux vm 5.11.0-20-generic #21+21.10.1 SMP Tue Jun 15 09:14:45 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

Now that a newer kernel is installed it will stay installed until a newer one lands into the repositories used by Elementary. Once the newer kernel lands into a supported Elementary repository your system will automatically update to it like any other kernel and everything should continue to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.