0

I've been using the AppCenter versions of applications when they're available, figuring your devs made sure they worked with the idiosyncrasies of elementary OS. However, the recent upgrade resulted in an unusable browser (image attached)Elementary OS AppCenter version of Firefox 89 fails on rendering all web pages

I uninstalled the version from AppCenter and installed the real one in the Ubuntu repository via Synaptic and, Bob's your uncle, I'm in business.

If you have the same problem, save a backup of your profile (bookmarks, history, etc.) or make sure Sync is working--I lost mine.

0

I also have the same problem. I have tried installing various ways, however, the problem doesn't go away. On firefox windows support, they suggested to start the browser in troubleshoot mode. If the problem goes away, they think it is caused due to some add-on active. I have disabled all the add-ons and the problem still persist. You may try if it works. (Help ==> Restart in troubleshoot mode)

0

Seems to be the problem only with that specific version. I have Firefox installed through snap and changing the channel to latest/beta solved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.