I'm having some troubles with installing a new kernel on my Elementary OS installation. I've installed the 5.11 kernel, and it's installed successfully, but the option to boot into the new kernel isn't showing up in grub. I've tried looking elsewhere and tried grub-update and other commands to try and update the boot options, but they still don't show up. Now, I am running the Elementary OS 6 Beta, so there may be some problems there, but I figured I'd ask in case anyone has a solution or has seen this happen in other versions of Elementary OS or other distros. Thanks in advance!

1 Answer 1


I experienced the same issue, which seems to be caused by the grub.cfg file not being written to /boot/efi/EFI/ubuntu/grub/grub.cfg, just to /boot/grub/grub.cfg. What I did was:

  1. Created a backup of /boot/efi/EFI/ubuntu/grub/grub.cfg
  2. Copied /boot/grub/grub.cfg to /boot/efi/EFI/ubuntu/grub/grub.cfg
  3. After rebooting I was able to select newer kernels from the Grub menu

I did this to test the 5.13 kernel with the eOS6 beta as sleep does not seem to work for me with a Ryzen 5500U CPU. With the new kernel the notebook goes to sleep just fine - but resume does not work :) One step at a time I guess, hehe.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.