2

I've installed Elementary OS 0.3.1 Freya on MacBook Pro2015 mid 15" with rEFInd used.

When I get into touchpad setting, some GUI elements are missing:

enter image description here

In Touchpad section, there's nothing.

HOWEVER if I move a mounse pointer around that empty space, GUI elements that were invisible appears:

enter image description here

My system configuraion is:

MacBook Pro 2015 mid 15"
Iris 5200 Pro graphic, no external graphic
Elementary OS 0.3.1 Freya 64-bit
Based on Ubuntu 14.04.1 (Kernel: 3.19.0-26)

And I have grub set:

GRUB_CMDLINE_LINUX_DEFAULT="acpi=noirq acpi=force apm=power_off nomodeset"

Loaded modules are here: https://gist.github.com/anonymous/caba4a2ff9f67f8c764f

Does anyone have a such issue and have fixed it?

2
  • I think it is because of the nomodeset option. I'm not sure how hard it is to install the correct graphics driver on a MBP?
    – Jeroen
    Nov 2 '15 at 11:08
  • I am having the exact same issue on my MacBook Pro 15" Late 2012 (rMBP 10,1). The Bluetooth dropdown panel in the menu bar seems to also be affected by this. I can reproduce this issue both by using the integrated Intel GPU as well as by using the dedicated Nvidia GPU with nouveau, therefore I think it might not be a driver issue. I am not using rEFInd, but booting via Grub2 directly. The parameters only include the acpi_osi='!Windows 2012' option, no nomodeset or anything else. Booting without it doesn't affect the problem. I hope this helps in pinpointing the issue. EDIT: I just noticed
    – adriaano
    Nov 24 '15 at 15:08
2

Switching to the elementary dark theme solved the issue for me, see UI elements are not displayed

Not the answer you're looking for? Browse other questions tagged or ask your own question.