0

I'm trying to contribute to Granite, but I'm still on elementary OS v5, which doesn't include the required vala computed version.

Thanks to jeremypw I found the relevant ppa:
https://launchpad.net/~vala-team/+archive/ubuntu/next

I installed the ppa:

sudo add-apt-repository ppa:vala-team/next 
sudo apt-get update

But then I struggled knowing what to install. valac itself was still at 0.40:

valac/bionic,now 0.40.25-0ubuntu1~18.04~valateam0 amd64 [installed]
  C# like language for the GObject system

I did find valac-bin:

valac-bin/bionic,now 0.52.2-0ubuntu1~18.04~valateam0 amd64 [installed]
  internal package for C# like language for the GObject system

After installing things look good:

valac --version
Vala 0.52.2

But when running meson I'm now getting this error:

meson build --prefix=/usr 
The Meson build system
Version: 0.49.2
Source dir: /home/peteruithoven/Projects/elementary/granite
Build dir: /home/peteruithoven/Projects/elementary/granite/build
Build type: native build
Project name: granite
Project version: 6.1.0
Native C compiler: cc (gcc 7.5.0 "cc (Ubuntu 7.5.0-3ubuntu1~18.04) 7.5.0")

meson.build:1:0: ERROR:  Vala compiler 'valac' can not compile programs

A full log can be found at /home/peteruithoven/Projects/elementary/granite/build/meson-logs/meson-log.txt
2
  • 1
    I think you need to install the matching valac-0.52-vapi package as well May 1 at 18:21
  • That was it! Thanks! Feel free to post it as an answer, that way I can indicate it as the answer. May 1 at 19:57
1

You need to install the matching vapi package (valac-0.52-vapi) as well the compiler binary (valac-bin).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.