1

In previous versions of elementray OS you could make "numeric pad keys always enter digits". See this answer and screenshot below:

enter image description here

This setting is also available on Ubuntu (see this answer).

However, in elementary OS 5, this setting is not available:

enter image description here

I don't know if I accidentally press the numlock key or it's some random bug, but I'm constantly trying to enter a number with the numeric pad and end up moving to the top of the document, enabling "insert" or deleting something. Is there any way of making sure that the numeric keyboard lives to its name and only enters numbers in elementary OS 5 (and hopefully the upcoming 6)?

Quoting this question:

Please note that I do not want to know how to turn Num Lock on at startup, I do not want to know how to tear the key off, I want to disable it so that it stays on all the time and can't be turned off by mistake. Any idea how to do that?

EDIT: Found this answer, that proposes this command:

setxkbmap -option numpad:mac

It works perfectly but it turns off seemingly randomly or after some time. To make it permanent, I need to edit 10-keyboard.conf (see here), but I don't know where to find it. For now I added that command to the startup commands and seems to work.

6
  • What happens if you install 'numlockx' and reboot? Try sudo apt install numlockx, press enter, authenticate, let it do its thing, and then reboot. It may be necessary to add it to autostart somewhere and I don't have my eOS VM handy to check that. – KGIII Apr 27 at 15:28
  • "numlockx is already the newest version (1.2-7ubuntu1)." I guess I had in installed already, so no change there. See the edit for further information on a possible solution. I add that running numlockx seems to prevent that solution from working. :\ – Elio Campitelli Apr 28 at 19:00
  • Add /usr/bin/numlockx to your startup sequence. Open the menu, type start, it's under applications > startup (or similar - my VM still isn't handy) and add the above as a startup item. Reboot and see if it takes. – KGIII Apr 28 at 21:21
  • Is it safe to assume that command did the trick? – KGIII May 1 at 15:19
  • No, it doesn't work. :( The Numlock key still toggles the numeric keyboard. My workaround right now is to use Keymapper to map numlock to escape. Not the most elegant solution. – Elio Campitelli May 5 at 12:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.