0

I have installed elementary OS freya and I am experiencing shutdown problem. I cannot shutdown or restart my computer, to do so I have to press power button.I tried:

shutdown -h now
shutdown -P now
shutdown from the UI

When I shutdown it shows

[2969.600864] init: wait-for-state (plymouth-shutdownlightdm) main process (14172) killed by TERM signal

I also tried to change GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub and changed CONCURRENCY to none in /etc/init.d/rc. Still no luck

Do I have to press power button everytime or is there any solution for this? Secondly, is doing so safe?

  • please edit your post and add the error message you got, when you executed the commands in terminal. (Please add total message--use copy&paste--no screenshots) – Ravan Nov 1 '15 at 4:47
  • okay, did that. Hope that helps – Lokesh Devnani Nov 1 '15 at 13:47
  • which command you used? – Ravan Nov 1 '15 at 13:49
  • Bizarre--without sudo you got that error. You have to use sudo befor other wise you will get shutdown: Need to be root message – Ravan Nov 1 '15 at 13:52
  • No, I tried doing shutdown both by using sudo shutdown -h now # as normal user and also by sudo su shutdown -h now # as root – Lokesh Devnani Nov 1 '15 at 13:57
0

I have installed elementary OS freya and I am experiencing the same shutdown problem. In my case I installed AMD Radeon driver (graphic card) to my hardware in Lenovo G50-80 laptop. Packages are in the repository:

# sudo apt-get install fglrx-core fglrxamdcccle
  • Thanks. Looks like it was the graphic driver that was causing the problem. I wonder when will the computer manufacturing companies start making drivers for all the machines they ship. – Lokesh Devnani Jul 4 '16 at 11:02
0

By Using terminal you can simply run following commands to shutdown and restart.

For Shutdown

sudo init 0

For Restart

sudo init 6

You will be asked to enter password, after entering password you are cool.

0

Try sudo shutdown -h <time in minute>

Example sudo shutdown -h 0

Try sudo shutdown -r <time in minute> for reboot in time.
Reboot can also use sudo reboot


Solution 1:
Edit /etc/default/grub file

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"  
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash reboot=pci"

Then run sudo update-grub

Source -- Link


Solution 2:
Edit /etc/default/grub file

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"  
GRUB_CMDLINE_LINUX_DEFAULT=""

Then run sudo update-grub

-1

This is very radical and application will not be closed properly. However, if you quit everything correctly that shouldn't be an issue.

sudo poweroff

will kill the power instantly, without waiting for plymouth. This is not recommended, but until this issue (which affects me too) is fixed, it should work fine.

My System:

System:    Host: FuckTheSystem Kernel: 4.4.6-040406-generic x86_64 (64 bit, gcc: 5.2.1) 
           Desktop: Gnome Distro: elementary OS 0.3.2 freya
Machine:   System: ECT product: N/A
           Mobo: Notebook model: W65_67SF Bios: American Megatrends version: 1.03.03 date: 04/01/2014
CPU:       Quad core Intel Core i7-4810MQ CPU (-HT-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 22349.8 
           Clock Speeds: 1: 2794.093 MHz 2: 2800.00 MHz 3: 2805.468 MHz 4: 2789.937 MHz 5: 2782.500 MHz 6: 2825.265 MHz 7: 2780.859 MHz 8: 2764.453 MHz
Graphics:  Card: Intel 4th Gen Core Processor Integrated Graphics Controller bus-ID: 00:02.0 
           X.Org: 1.17.1 driver: intel Resolution: 1920x1080@60.0hz 
           GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 10.5.9 Direct Rendering: Yes
Audio:     Card-1: Intel 8 Series/C220 Series High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0 
           Card-2: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller driver: snd_hda_intel bus-ID: 00:03.0 
           Card-3: Logitech driver: USB Audio usb-ID: 003-006 
           Sound: Advanced Linux Sound Architecture ver: k4.4.6-040406-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller 
           driver: r8169 ver: 2.3LK-NAPI port: d000 bus-ID: 04:00.2
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: 80:fa:5b:06:6f:e4
           Card-2: Intel Wireless 3160 driver: iwlwifi bus-ID: 03:00.0
           IF: wlan0 state: up mac: 30:3a:64:54:c7:7f
Drives:    HDD Total Size: 370.1GB (3.8% used) 1: id: /dev/sda model: Samsung_SSD_850 size: 120.0GB temp: 0C 
           2: id: /dev/sdb model: Samsung_SSD_840 size: 250.1GB temp: 0C 
Partition: ID: / size: 213G used: 14G (7%) fs: ext4 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 14.0C mobo: N/A 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 275 Uptime: 59 min Memory: 1072.9/15931.8MB Runlevel: 2 Gcc sys: 4.9.3 
           Client: Shell (bash 4.3.11) inxi: 1.9.17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.