0

elementary OS 5.1 Hera

Issue in a Nutshell: The disk space for elementary OS seems to have recently ballooned significantly. I have elementary OS on a ~105GB partition. Recently, I saw the Files app reported that the File System was using a staggering 86.1GB.

What I Tried Manually going through the folders from root to try to identify where the sudden disk usage was. Then I tried:

cd /
sudo du -h --max-depth=1 --exclude=media --exclude=run --exclude=proc

The dh report shows:

16M ./bin
1.5G    ./var
4.7G    ./usr
4.0K    ./srv
16K ./lost+found
24M ./onedrive
709M    ./snap
11G ./home
272K    ./opt
4.0K    ./lib64
170M    ./boot
0   ./dev
4.0K    ./cdrom
0   ./sys
977M    ./lib
5.8M    ./lib32
17M ./sbin
604K    ./root
4.0K    ./mnt
20M ./etc
132K    ./tmp
21G .

I am puzzled by the reported 21GB in root. I see no files in root (ls -la) anywhere near that size (there is a unused 2GB swapfile).

Questions

  1. What does the 21GB mean in the dh report?
  2. Why would there be a mysterious 21GB chunk?
  3. Is there a standard reason why elementary OS would be ballooning like this? I am almost out of space.
  4. The home directory at 11GB seems to be primarily in the /home/me/.local directory. I use very very very little actual space in /home for documents etc. (Most of the data is stored on a separate server partition.)

I installed elementary OS 5.1 Hera about three months ago and use it normally (plain vanilla install). I minimize apps installed to core apps.

2
  • Not an answer, but i like to use Disk Usage Analyzer from the AppCenter when looking for balooning files. It has a really nice and easy to use interface. Maybe it can help you find the problem?
    – Vlad
    Apr 12 at 20:03
  • You can open the file manager as root and browse through /root to see what's in there.
    – KGIII
    Apr 12 at 22:49
1

Thank you @Vlad and @KGill. I used both techniques. The Disk Usage Analyzer is a handy visual means to find large directories. I did not know that elementary OS allows running File Manger as Administrator. I keep File Manger in the DOCK and a right-click on the icon offers the Run as Administrator option (never noticed that before, thanks).

Using your suggestions, I was better able to identify the issue.

Oddly, there was a ghost mount under /media/{me}/{partition ID} to an external thumb USB drive. For some reason, a rsync a week or so ago somehow seems to have copied to that mount point but on the SSD partition because it appeared as if the files were physically copied to the / root drive. I know this sounds strange but that is why the install suddenly ballooned. The ghost mount point had about 52GB which made my install suddenly shoot from about 20GB to 80+GB.

I analyzed this ghost mount point using sudo blkid (no mount evident), checked sudo nano /etc/mtab and sudo nano /etc/fstab (no mount) and fidisk -l (no mount). Also tried umount (the ghost mount) and no mount.

I copied the ghost mount to another external drive just in case and then forced a removal of the ghost mount point using sudo -r /media/{me}/{the mount point partition ID} . This did indicate activity on the main SSD drive where the Linux partition lives so maybe there were files somehow on the SSD drive (not the original external USB now showing as a ghost) . Using Disk Usage Analyzer and Files, both now show the install returned to about 20GB.

Whew! Thanks to both of you for advice. I am still not sure why this occurred but I did run a rsync to an external thumb drive last week. Maybe I messed that up somehow and it copied instead to the main SSD drive.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.