0

It appears I have installed everything I need to borrow DRM epubs, but the ADE launch fails. ADE requires WINE without a linux edition, but I ran into a wall and I'm out of ideas on how to proceed. The dead end was addressing a "Broken NVIDIA RandR" error.

WINE v6.0 is working, installed manually using web advice; AppCentre's WINE v3.0 was a dysfunctional mystery.

  • Windows installers/uninstallers work okay in WINE
  • Adobe authentication and ADE computer registration okay, tested in ADE 1.7
  • .NET 4.6/WINE Mono install probably okay; ADE 4.5 and .NET 4.6 born only months apart, older revs no effect
  • manual .NET 4.6 install stops early to report already installed, newer refuses install
  • ADE 1.7 - launches but won't load ACSM links, bad link/generic network error #2038
  • ADE 3.0 - AppCentre icons but launch fail
  • ADE 4.5 - AppCentre icons but launch fail
  • multiple installs/uninstalls, manual over-installs, and Winetricks no effect (only ADE v1.7, v4.5 listed)
  • ADE v3.0 and v4.5 from the command line flag the same "mscoree.dll not found"
  • ADE 3.0 ran okay on a shared subnet Mac, no firewalls/proxies
  • Nouveau driver swap did nothing, except kill some unrelated OpenGL requirements
  • mscoree.dll exists in both 32bit/64bit ADE and Windows directories, from .NET Framework
  • switching Windows version environments in winecfg no effect
  • Calibre not involved, DRM needs ACSM key to download EPUB, ADE sole solution
  • everything appears in order inside the .wine C drive, just my opinion

I'm not sure where to turn next. Is this a .NET, WINE, or file system issue? If I use winecfg to remove or tweak the dll override settings I found within, I lose the missing dll error but trade it for the RandR error (plus an ox-stunning list of exceptions that follow). I assume the toggled error messages mean the dll override is something that shouldn't have been there and .NET's dll is working okay.

WINE tools also give me the "Broken NVIDIA RandR" error, but they work with WINE's auto-substitution applied. RandR repair is documented online but the fix doesn't work without an /etc/X11/xorg.conf file, and I'm scared to death I'll lose my video on the last computer I have available. Should I create an xorg.conf file just for the single line <Option "metamodes" "1920x1080 +0+0">?--although I'd try a different resolution. Launching ADE might flag the RandR error, but I don't have proof that's what's aborting launch, only an obvious guess.

I was fine with ADE v1.7 as I just move everything into Calibre anyway, but I tried two Overdrive books and got the same network #2308 error; it doesn't feel like a network problem when my network was fine using ADE on a different computer. ADE v1.7 is so old it may not be worth understanding.

This leaves me with the RandR issue as an opening. Would I be able to back out of an xorg.conf scratch test, maybe look up that file formatting on the web with a safe boot to delete it if it fails?

1
  • It appears the RandR error can be ruled out and ignored. It reports thrown for almost everything based on an NVIDIA setting, and the working WINE utilities, with same error, are evidence that ADE would probably work too if not for some other problem. Reinstalling all involved from scratch for a clean slate. Also, found a WINEHQ comment that the latest versions of everything should be ok, so I will stop backtracking revs. – SkyHook Apr 6 at 2:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.