0

The short, technical version: upon initial installation of Elementary 5.1.7 onto a Lenovo Flex 5 AMD Ryzen 4700U I am unable to connect to wifi. The Network settings read “Wireless Is Disabled” despite wifi being switched “on.” I was not able to connect to Wifi while installing from USB (as some users I’ve found via googling have mentioned). The wifi card in this machine is a Realtek 8822CE Wireless LAN 802.11ac PCI-E NIC. Looking around I’ve found something that has worked for someone else with the card here -

https://askubuntu.com/questions/1180714/realtek-rtl8822ce-is-unable-to-detect-wifi-networks

I’ve opened terminal and typed in “dmesg” and the diagnostic stuff that comes up pulls the error that that user was getting. However, the command that fixes things for them -

wget http://security.ubuntu.com/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.178.3_all.deb sudo dpkg -i linux*.deb

I don’t think I can use because I’m not connected to the internet. Moving over to the windows partition I’ve gone to download that firmware pack but it doesn’t look like it’s hosted there anymore. Is rtw8822c_fw.bin something I will be able to get from a later Linux firmware package from the same source? If I download another package, bring it over to my Elemetary side, navigate in terminal to the folder it’s in and enter the

sudo dpkg -i linux*.deb

command, will that... fix.... the wifi?

As you might have guessed, I’m basically completely new to Linux (tried to use Red Hat for a month back in high school uhhh 19 years ago) and wanted to give Elementary a try. Thank you in advance for your patience!

0

I was sitting around refreshing this page waiting for an answer and then I was just like well why don’t I just go ahead and try the possible solution I mapped out? So I downloaded a newer firmware from that location, fired up Elementary, opened terminal, navigated to a folder where I had placed the .deb file* and then entered the sudo command. Something... happened, which looked promising. I rebooted and wifi worked! Just answering this in case another novice user has this problem, or so that someone who knows that they’re doing can come on and scold me for doing something silly!

  • This is probably not necessary context for most users of this forum but as a terminal newbie I’m always confused when people are just like “enter whatever
0

Welcome. I think your issue will resolve follow these site:

CODE LINES YOU HAVE TO EXECUTE IN TERMINAL: https://medium.com/@kimiyukiyukawa/installing-rtl8821ce-network-controller-on-ubuntu-335d8ccb8a92

<BR>

REPOSITORY (IF YOU WANT TO TAKE A LOOK BECAUSE YOU HAVE A LENOVO LAPTOP): https://github.com/tomaspinho/rtl8821ce

In my case, to execute the code in terminal, I connected my cellphone with USB cable and shared internet connection.

regards and happy Elementary experience

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.