1

I can go into Freya's Tweaks in Settings to have Close, Minimize, and Maximize appear on the top right of each window, but this does NOT seem to work for Google Chrome. The Close 'X' is still appearing on the upper left of the window even after applying the Tweaks settings.

Any way to change this?

  • please edit your question, because your accepted answer won't change close button to right side. But in your question you have mentioned to change close button as well =)Also there is nothing to worry about using command which was tested – Ravan Nov 5 '15 at 4:48
  • The accepted answer also puts the close button on the right... – fuzzybabybunny Nov 11 '15 at 6:18
  • nope, close button still on left, – Ravan Nov 11 '15 at 6:21
  • see my edit @fuzzybaby can you justify your comment ? – Ravan Nov 11 '15 at 6:52
3

Go into google chrome settings and in apperance you will find use system title bar and borders check it and that'll do.

  • Thanks, that did the trick. I chose this one as the answer because it's a setting in Chrome itself, so I reckon it's a bit safer than running the command line stuff. – fuzzybabybunny Nov 3 '15 at 5:42
2

If you want to have minimize , maximize and close buttons on top right of chrome :

Open terminal and run:

gconftool-2 --set /apps/metacity/general/button_layout --type string ":minimize,maximize,close"

Now restart chrome.

GUI method:

Install gconf-editor:

sudo apt-get install gconf-editor

Now Open configuration-editor --> apps-->metacity--> general, select button_layout and right click --> Edit Key.

Now add value :minimize,maximize,close

Imgur

Note : If you enable use system title bar and borders It will not work.So make sure that was disabled. I have tested it in freya.


how to rollback?

Open configuration-editor --> apps --> metacity--> general

Now in right side of the window, select button_layout and right-click select Unset key.

Now restart chrome.


EDIT: To give clarity

At first:

Imgur


Adjusting settings-

Imgur

After still close button on left:

Imgur


After executing command in my answer :

Imgur

  • This gconf solution doesn't work anymore in Loki - I suspect it's due to something in the newer versions of Chrome/Chromium and perhaps the Aura graphics stack. – jena Nov 5 '16 at 8:17
  • it finally works again in chromium 55 – jena Jan 3 '17 at 12:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.