2

I had setup lamp-server^ for local development environment, then just a few minutes ago it cannot find server any more. I wanted to purge it to install XAMPP but am getting another error, how can I identify and resolve this error please?

sudo service apache2 start

  • Starting web server apache2 *
  • The apache2 configtest failed.
    Output of config test was:

    [Tue Oct 27 12:36:03.639362 2015] [alias:warn] [pid 9944] AH00671: The Alias directive in /etc/apache2/conf-enabled/phpmyadmin.conf at line 3 will probably never match because it overlaps an earlier Alias.
    AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
    (2)No such file or directory: AH02291: Cannot access directory '/var/log/apache2/' for main error log
    (2)No such file or directory: AH02291: Cannot access directory '/var/log/apache2/' for error log of vhost defined at /etc/apache2/sites-enabled/000-default.conf:1
    AH00014: Configuration check failed
    Action 'configtest' failed.
    The Apache error log may have more information.
    

Then this:

sudo apt-get purge lamp-server^

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'mysql-server-core-5.5' for task 'lamp-server'
Note, selecting 'mysql-server-5.5' for task 'lamp-server'
Note, selecting 'libaio1' for task 'lamp-server'
Note, selecting 'mysql-client-core-5.5' for task 'lamp-server'
Note, selecting 'apache2-mpm-prefork' for task 'lamp-server'
Note, selecting 'libaprutil1' for task 'lamp-server'
Note, selecting 'libapache2-mod-php5' for task 'lamp-server'
Note, selecting 'php5-mysql' for task 'lamp-server'
Note, selecting 'php5-common' for task 'lamp-server'
Note, selecting 'libaprutil1-dbd-sqlite3' for task 'lamp-server'
Note, selecting 'php5-readline' for task 'lamp-server'
Note, selecting 'ssl-cert' for task 'lamp-server'
Note, selecting 'mysql-client-5.5' for task 'lamp-server'
Note, selecting 'libhtml-template-perl' for task 'lamp-server'
Note, selecting 'libterm-readkey-perl' for task 'lamp-server'
Note, selecting 'libaprutil1-ldap' for task 'lamp-server'
Note, selecting 'mysql-common' for task 'lamp-server'
Note, selecting 'php5-cli' for task 'lamp-server'
Note, selecting 'libmysqlclient18' for task 'lamp-server'
Note, selecting 'apache2-data' for task 'lamp-server'
Note, selecting 'php5-json' for task 'lamp-server'
Note, selecting 'libapr1' for task 'lamp-server'
Note, selecting 'apache2' for task 'lamp-server'
Note, selecting 'mysql-server' for task 'lamp-server'
Note, selecting 'apache2-bin' for task 'lamp-server'
Note, selecting 'libwrap0' for task 'lamp-server'
Note, selecting 'libdbd-mysql-perl' for task 'lamp-server'
Note, selecting 'tcpd' for task 'lamp-server'
Note, selecting 'libdbi-perl' for task 'lamp-server'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libpulse0 : Depends: libwrap0 (>= 7.6-4~) but it is not going to be installed
  pulseaudio : Depends: libasound2-plugins but it is not going to be installed
          Recommends: pulseaudio-module-x11 but it is not going to be installed
          Recommends: gstreamer0.10-pulseaudio but it is not going to be installed
          Recommends: pulseaudio-utils but it is not going to be installed
 E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

closed as off-topic by bigbang, elmato, Lewis Goddard Dec 15 '15 at 22:57

  • This question does not appear to be about elementary OS, within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Have you try to remove the install you've made and make a clean new install? – td18 Oct 27 '15 at 14:47
  • 1
    That is what I was trying to do. After it failed to start, I opted to purge and re-install but it failed. So I could not remove. I therefore took another route, uninstall whole Elementary OS system and installed Lubuntu. So this question has become obsolete, as of now - though somebody may get to the same point one time. – HostMy5 dot Com Oct 27 '15 at 23:49
  • 2
    I'm voting to close this question as off-topic because it is more for Apache than elementary OS. – bigbang Dec 12 '15 at 11:48

Browse other questions tagged or ask your own question.