Back in the Luna days I used ibus to type in Japanese, and could switch between input methods using CtrlSpace.

In Freya, I've tried to install ibus through the terminal, looking through the ibus page on the Arch Linux wiki and following instructions there, and all to no avail.

Is there a way to get ibus working, or and alternative method that will work just as well?

  • Work on elementaryOS Loki 0.4.1 12018.01.26 HE. – ThatCuriousYui Jan 26 at 14:29

I found that ibus did not work with Freya. Instead I used fcitx with mozc for Japanese Input, using the instructions from the elementary os subreddit.

NOTE: Make sure you remove the ibus package before you go through the folliwng steps, else the input-switcher will not work.

  1. Add the Fcitx repository: sudo add-apt-repository ppa:fcitx-team/nightly
  2. Update package list: sudo apt-get update
  3. Install fcitx, fcitx-mozc, and im-config: sudo apt-get install fcitx fcitx-mozc im-config
  4. Configure input method by running: im-config
  5. Select "OK", on the dialog box that pops up.
  6. When asked to update user preferences, select "Yes".
  7. Select fcitx from the list, and select "OK".
  8. Restart your computer, and you should see an icon for fcitx in the wingpanel. enter image description here
  9. Click on the icon and if Mozc is not already under the Input Methods, click on configure. Click on the Plus icon at the toolbar at the bottom. Uncheck the checkbox for "Only Show Current Language". Search Mozc, and add it.
  10. Ctrl+Space is used to switch between inputs. Input Selector
  11. Since the mozc configuration tool will not open from the indicator, you can use the following command to open it. /usr/lib/mozc/mozc_tool --mode=config_dialog
  12. If everything went well, you may have noticed that the icon for mozc by default is too big, so wingpanel will resize everytime you input with mozc. To avoid this, you can replace the icon with this smaller one in /usr/share/fcitx/mozc/icon/. You can download a copy of the mozc.png icon here, make sure you replace the old mozc icon with this. Once you replace it, open up terminal, and enter chmod 777 /usr/share/fcitx/mozc/icon/mozc.png, to ensure that the icon will be displayed properly.
  • 1
    No need for the edit tags, just place the edited text where it belongs similar to a Wikipedia article so everything is in (chrono-)logical order :) – quassy Jul 20 '15 at 16:16
  • Thanks for very useful article. Cannot make it work though. I'm able to choose mocx among Input Method, but looks like it does not affect writing. Can you help me? How this should work? And Ctrl+Space does not seems to work too... – orkenstein Dec 20 '15 at 10:32
  • @orkenstein I had a similar issue as I went through this. For me, it was because the ibus package was not removed before setting up mozc. I'd recommend removing the ibus and fcitx packages that you just installed, and reinstalling just the fcitx packages. – Daichi Dec 24 '15 at 23:43

You can change the keyboard layout in System Settings > Keyboard > Layout and add a new layout there with the plus button in the bottom left. I have no knowledge of Japanese signs, but enabling a Japanese (Kana) seemed to work for me.

The default shortcut to cycle through different keyboard layouts in Freya is AltSpace. You can change this in System Settings > Keyboard > Shortcuts > Universal Access.

Also there are some special settings for Japanese input(Keyboard -> Options -> Japanese keyboard options). Check attached screenshot:

Screenshot showing Japanese keyboard options in System Settings

  • This is not a good solution. Most Japanese input requires the user to type using a standard US keyboard layout and phonetically type the words eg. "watashi ha biru desu" ... Whilst this does allow the user to type in Japanese, it does not allow it in any way in which most users will be familiar with. – Bill O'Dwyer Jul 19 '15 at 23:05
  • Thanks for the feedback, as I said I don't know much about Japanese, so this seemed to like the obvious solution to me but apparently it's not the best. The answer from Daichi seems to be more elaborate :) – quassy Jul 20 '15 at 16:26

If you wish to use Japanese input follow the elementary subreddit here but with step (3) replaced with either

sudo apt-get install fcitx fcitx-anthy im-config

sudo apt-get install fcitx fcitx-mozc im-config

Depending on whether you wish to use (discontinued but widely used) anthy or (maintained by Google) mozc input.

I can confirm this works with elementary OS 0.4.0 Loki, as of 2016-09-11

  • OK, why did someone immediately vote my comment down? What is wrong with me posting that these instructions work perfectly in Loki? – Gemma Seymour Sep 11 '16 at 20:14
  • I assume that was because it should be a comment. Hang on, I'll move it. – Lewis Goddard Sep 12 '16 at 15:56
  • 1
    Wait, which answer are you referring too? – Lewis Goddard Sep 12 '16 at 15:56

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.