7

I had installed beta version of Freya alongside windows 7 about a year ago. I didn't use or update Freya after a month of use. But today I updated it by apt-get update && apt-get upgrade and also from software updater. Now, after that process, software center does not open by clicking the icon. All other apps work normally. Any suggestions?

Edit: When I open it from terminal, it says:

** (software-center:9741): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-wwFmjNgyPS: Connection refused
2015-10-25 23:09:13,460 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
Traceback (most recent call last):
File "/usr/bin/software-center", line 130, in <module>
app = SoftwareCenterAppGtk3(options, args)
File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 407, in __init__
self.icons)
File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/historypane.py", line 79, in __init__
self._get_emblems(self.icons)
File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/historypane.py", line 199, in _get_emblems
pb = icons.load_icon(emblem, self.ICON_SIZE, 0)
gi._glib.GError: Error opening file: No such file or directory
  • try reboot =)... – Ravan Oct 25 '15 at 17:50
  • Tried it multiple times. – 8bitrebellion Oct 25 '15 at 17:54
  • I got same message , but SC opened:\ have you run software-center in terminal ? – Ravan Oct 25 '15 at 17:58
  • problem solved ? – Ravan Oct 27 '15 at 16:04
  • Yes..by reinstalling icon themes. sudo apt-get install --reinstall humanity-icon-theme elementary-icon-theme – 8bitrebellion Dec 24 '15 at 17:09
5

it can't find a missing icon, for me its: /usr/share/icons/elementary/actions/16/package-install.svg

FIX

edit file: /usr/share/icons/default/index.theme and make sure "Inherits=" line includes icon theme that contains this missing iconm, eg:

Inherits=elementary,Humanity

  • Yes by reinstalling both theme did the trick. Thanks. – 8bitrebellion Dec 24 '15 at 17:07
2

Depending on your theme (mine was Pacifica), it was missing the actions icons.

To solve the errors (see first post above) you need to copy the missing icons from the Humanity icontheme:

Example in terminal (create directory, copy files):

sudo mkdir /usr/share/icons/Pacifica/16x16/actions

sudo cp -rp /usr/share/icons/Humanity/actions/16/* ../../../Pacifica/16x16/actions

Just in case, copy all possible sizes based on the target icontheme. After that, just start software center via "Applications > System Tools".

Works fine.

  • Yes by reinstalling both theme did the trick. Thanks. – 8bitrebellion Dec 24 '15 at 17:08
2

Removing Software Centre's cache could help:

killall software-center
sudo rm -r /var/cache/software-center/xapian
sudo mv /var/lib/dpkg/info/format /var/lib/dpkg/info/format.bak
sudo dpkg --clear-avail
sudo apt-get update
sudo apt-get install --reinstall software-center

The first command should return software-center: no process found

From the comment by OP, The problem solved after re-installing both the themes.

sudo apt-get install --reinstall humanity-icon-theme elementary-icon-theme
  • Hello, it didn't work. But I reinstalled humanity-icon-theme and elementary-icon-theme. It worked. Thanks. – 8bitrebellion Dec 24 '15 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.