15

I am used to using Super on Ubuntu to open the search. Can I set Super to be the shortcut instead of Alt+F2?

Or does elementary OS not support Modifier key only bindings? I know that OS X doesn't because I wanted Super for the Spotlight search, and couldn't have it.

  • 2
    I too would prefer to just use the Super key, but I remember reading somewhere that it was not possible. Let's see what people with more knowledge say about this. – Gabriel Jun 30 '15 at 19:15
  • I believe there's an issue where the <kbd>Super</kbd> key is trapped somehow, and undetectable. I believe it's an upstream Gnome thing. – Lewis Goddard Jun 30 '15 at 21:23
  • 1
    Although not as convenient as only <Super>, <Super> + <SpaceBar> does the same as Alt + F2 – John Guerreiro Jun 30 '15 at 22:11
  • Do you want to change the super key to open slingshot, is that what you're asking? – Crutchcorn Jun 30 '15 at 22:26
  • there is also Super-Space. Clicking it a second time closes Applications, a feature that is not present in Alt-F2 and is not present in the solution that replaces that. – user170 Jul 5 '15 at 15:22
12
  1. Open the Terminal by holding Super and pressing T

  2. Run this command:

gsettings set org.gnome.desktop.wm.keybindings panel-main-menu "['Super_L', 'Super_R']"

  1. Either revel in the glory of your newfound shortcut, or change back by running:

gsettings set org.gnome.desktop.wm.keybindings panel-main-menu "['<Super>space', '<Alt>F2']"

  • there is a little problem though: the new Super key lacks a feature that is present in Super-Space. Indeed, your solution replaces ALT-F2, not Super-Space, which pressed a second time also closes Applications – user170 Jul 5 '15 at 15:23
  • 1
    Much better improvement of my answer. Good work – Crutchcorn Jul 10 '15 at 1:03
  • 4
    Do note that this will mess with all other shortcuts that use Super and is the reason it's not the default. i.e. Super left/right to switch workspaces gets weird because now the app launcher is opening, super+drag to move windows around gets messed up, etc. – Cassidy James Jul 17 '15 at 19:55
  • hi, I am not sure what command I used to change to <Super>space to <Super> as I did that a long time ago, I tried the second command but it did not change. Now all three combinations open app launcher. – Gaurav Kumar Sep 21 '17 at 10:00
6

You can set slingshot to launch by only pressing the super key by typing the following command into your terminal:

gsettings set org.gnome.desktop.wm.keybindings panel-main-menu "['Super_L']"
  • Was looking for that entry to complete my answer since I had it configured that way in my system. Also useful to change Super + Up to toggle-maximized – John Guerreiro Jun 30 '15 at 22:53
  • I just have a list of things I do to configure my eOS installs. Luckily, that was on that list. :) – Crutchcorn Jun 30 '15 at 22:55
  • This is the answer, thank you very much @Crutchcorn! – Gabriel Jul 1 '15 at 0:20
  • Anytime! Glad I could help – Crutchcorn Jul 1 '15 at 4:30
  • 2
    @Tim The default setting is ['<Super>space', '<Alt>F2'], so I would assume ['Super_L', 'Super_R'] would work for both. – Lewis Goddard Jul 1 '15 at 9:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy