0

Context; saving Mac backups using another PC with eOS boot SSD to store duplicates. Repeatable failure using Files to copy music archive, about 15K item count and 125GB total. The source is iTunes storage in the style of Music/Artist/Album/Song:

  • external 2TB cap HDD over USB, fast enough, feels like a five minute copy if it could finish
  • scroll dialogue opens with correct count/size
  • scroll stops reporting around the 1st GB, probably hung
  • system monitor reports about 50% CPU then squats there, probably hung
  • file destination quickly reaches about 30GB, but best attempt was 64GB
  • directory check shows some jumping around, but somewhat alphabetical with gaps
  • new attempts repeatably copy or skip the same subdirectories, although stopping at varied points
  • some system files without read permission skipped, as expected
  • not asking me to skip unreadable after first attempt, maybe cached response?
  • similar results whether drag-drop or context menu copy-paste
  • no problems with copied heirarchy structure
  • can successfully copy missing, nested directories individually
  • can successfully copy smaller samples, up to 6GB so far

I'm proceeding with my manual workaround, a few GB at a time so I can check results before moving on; for example, the "As" were about 3GB and I could count subdirectories on my fingers and toes. Smaller bites won't take long but I'm asking about Files behaviour because the unexpected failure is disturbing. The silver lining is that it's obvious something is wrong by checking top level count/size if the dialogue appears frozen.

Does Files have known hard limits or throughput problems? Please don't worry about my expectations; I still recall swapping 5MB pie platters and 10MB tapes, so copying 15K file systems is magic. I didn't find other complaints or recommended Files replacements online, which suggests my issue might be local.

2
  • Same problem, copying large data sets between external HDD's via FILES stops the copying process, or it appears to be completed but it failed to copy all files. Very annoying, time to Switch to other Linux version??? – Rik Mar 15 at 20:29
  • I wouldn't give up so easily, but it's tiring learning everything the hard way. Lack of user feedback is a definite trend I'm seeing in eOS applications. Just like a room full of programmers, everyone is proud of what they've accomplished but trying to address usability is like pulling teeth, only revisited if somebody points out the emperor has no clothes. – SkyHook Mar 18 at 3:45
1

There are a number of outstanding issues reported against Files in relation to file operations involving very large number of files. Files is currently best used for small to modest amounts or data (<10K items?). A crash might be caused by a memory leak for example. One of the proposals for this year's GSOC is the improvement of the aspect of Files.

Note also that because the system might cache file operations, Files may think that the operation is complete but it is still continuing in the background.

I would recommend using a specialist program like Grsync for backing up large volumes of data rather than a general purpose file manager. Or you could install another filemanager from the AppCenter. If you otherwise like elementaryos then there are certainly solutions other than switching to another distro.

4
  • Unfortunately, file or manager just return umpteen hits in AppCentre. Feel free to recommend a graphical file manager if you know it works on eOS. The reason I decided to try eOS was to experience what Apple sects think of canon from the Vatican, but I seem to be dumping every default tool in favour of 3rd party or command line. I should have appreciated Mac OS homogeneity more before I ran out of money; the frequent iteration approach to software sounds perfect described, but in practice waters down complexity, completion, and avoids hard questions in favour of the proletariat. – SkyHook Mar 18 at 3:39
  • Sorry, didn't really address what you said. I'm not backing up, just trying to copy, to make a distinction. I have yet to address backups or synchronization, a project for another day. – SkyHook Mar 18 at 3:48
  • The default Gnome filemanager is "Nautilus". If you search for this in Appcenter, it appears with the generic name "Files" with a blue filing cabinet icon. This works on elementaryos. You may want to also install the Nautilus Script Manager to add similar functionality to the elementary Files plugins. – Jeremy Wootten Mar 19 at 9:55
  • The Wootten answer is correct in practice, while unexpected, so I'll check it off. To paraphrase, Files doesn't work that well so try another file manager. I tried Nautilus as suggested, and just went for the gold ring, dragging the entire directory over and walked away. 124.5GB when complete, matching size and count from the destination, no issues as yet. – SkyHook Mar 22 at 3:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.