1

I’m on Elementary 5.1. Unable to copy .mpg files back to my USB. The file is around 5.5GB. My USB drive has more than 15GB of space free. I’m new to Linux, so I use the GUI default copy + paste for my needs.

For some odd reason, the copy progress bar stops at the 4.4GB mark and just conks out. I get the “file is too large....” similar error. Please assist.

2

I think it is due to the FAT32 max file size limitation. You can read more about file systems here: Transferring a 4GB or larger file to a USB flash drive or memory card

In short, you most likely need to format your USB drive to a different file system. There are many ways to do that, but the most intuitive way to me is using the GNOME Disks application from the AppCenter.

WARNING: this will delete everything from your drive, so make ure it does not contain anything you might need later!

After installing it, plug in your drive, launch the application, select your drive in the left column and then click the gear wheels and select Format Partition...

enter image description here

Next, give your drive a new name and select NTFS (or you can use the Other option to select exFAT) and click the Next button and then the big red Format button. enter image description here

After it completes, replug your drive and try copying files again.

2
  • Thanks for the assist, Vlad!
    – Nate Avi
    Feb 28 at 17:35
  • My pleasure :D And welcome to StackExchange. Remeber to upvote useful answers and accept the ones that solve your questions.
    – Vlad
    Feb 28 at 19:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.