I dual booted my laptop to have windows 10 and elementaryos 5.1 hera. I was updating some apps from appcenter and cancelled 2 updates (i assume this is what caused the problem). I now cant login no matter what I do and i've checked all the posts here about it and it doesn't fix anything. I have a lot of files on it so I would like to keep them is there any solution to this problem? I really like this OS and i would try anything to get it working again.

1 Answer 1


This looks like greeter is having trouble but that means your computer is booting properly. Can you login using a different TTY? Press Ctrl+Alt+F1 or possibly Ctrl+FN+F1 on a Macbook to access a different TTY. You can finish your update from the command-line with sudo apt upgrade. To reboot after finishing the updates you can run systemctl reboot.

If you still have issues it appears that many people have solved this by changing the ownership of the ~/.Xauthority file to the appropriate user. You might have already tried this but I'll include in just in case. You can reference the solution here and I've included it below.

  1. Login to your user account through a different TTY by pressing Ctrl+Alt+F1 or possibly Ctrl+FN+F1 on a Macbook.

  2. Set the permissions on the ~/.Xauthority file so that you own the file.

sudo chown $USER:$USER ~/.Xauthority
  1. Reboot.
systemctl reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.