1

I have 4 drives in my current system. Elementary defaults to files being placed on the 1st drive in the system and sets up default folders for users. I however, want to store my files on a large (1 TByte) spinning drive and temporary files on an SSD for rapid read and write. My system drive is an NVME.

Now my issue. I've tried various times to RENAME the drives, but they still show up as a long alpha-numeric name that makes sense to Elementary, but I'm not sure how to get the name to show up correctly in the File Manager.

File_Manager

Note that in the File Paths section the name is listed correctly, but not on the Left Sidebar.

1
  • The sidebar shows the drive identifier (GUID or the label if available) whereas the path barshows the path being shown in the view. So the answer below is the solution for the sidebar. However, your image shows a difference between the tab label (which is showing the GUID) and the path which is not expected. Might be worth raising an issue about at github.com/elementary/files/issues – Jeremy Wootten Feb 8 at 11:03
2

It appears Files is showing the partition unique GUID. If you label the volume you're mounting, Files should show that instead. The method to do this varies depending on the filesystem of the volume.

GParted and GNOME Disks offer great graphical interfaces for changing labels. Both applications are available in AppCenter.

Labels can also be changed via the command-line as outlined below.

For ext2/ext3/ext4 filesystems use the e2label command to label the partition.

e2label /dev/XXX "new label"

For btrfs use the btrfs filesystem subcommand.

btrfs filesystem label /dev/XXX "new label"

The Arch Wiki details the specific command for many more filesystems here.

0

Thanks for the heads up on the e2label command. I'm fairly new to Linux and the terminal (which is why I chose Elementary over other distributions). I ran the e2label command on the drives discovered with a df command and got the following:

kurt@kurt-Z490-VISION-D:/$ sudo e2label /dev/sda1 Cache

kurt@kurt-Z490-VISION-D:/$ sudo e2label /dev/sdb1 Storage

kurt@kurt-Z490-VISION-D:/$ sudo e2label /dev/nvme0n1p2

So they are apparently named correctly. I used the GParted Partion Editor from the AppCenter to rename them. I will repost this issue as a bug. Thanks.

1
  • Thanks for the feedback, I'll update my answer to recommend GParted / GNOME Disks. – jwillikers Feb 9 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.