i installed elementaryOS on my iMac 2011 using this tutorial: https://aroman.github.io/elementary-on-a-mac/

unfortunately i messed point 5. i ran $ ubiquity without the -b flag.

enter image description here

now i cant boot to macOS using long press Option key on boot. iMac just boots straight to elementaryOS. below is what Gparted shows:

enter image description here

how do i fix this? i would like to keep an old macOS like Snow Leopard around, while dedicating most storage to elementaryOS and other OSes i might want to try.

1 Answer 1


The Grub bootloader will have been installed to the EFI partition and registered as the default bootloader with your Mac's firmware as documented in the Debian Wiki here. That's why your Mac is booting directly to elementaryOS.

To remedy this, you can do the next section of the tutorial, Install rEFInd Boot Manager, directly from elementaryOS. Installing rEFInd should allow you to boot into macOS again. Installing rEFInd on Linux is documented on rEFInd's website here. Below I outline the steps you need to follow to install rEFInd on elementaryOS and boot back into macOS.

  1. Boot into elementaryOS.

  2. Log in and open Terminal.

  3. Install the software-properties-common package so that you can easily add rEFInd's PPA repository.

sudo apt -y install software-properties-common
  1. Add the rEFInd PPA to your system.
sudo apt-add-repository -uy ppa:rodsmith/refind
  1. Install rEFInd.
sudo apt -y install refind
  1. Confirm when asked if you want to install rEFInd to your ESP.

  2. That's all that is required to install rEFInd, so reboot.

  3. When the computer is booting, it should show the rEFInd menu. Select the macOS option and press enter.

  • it worked! thank you :)
    – Niyog Ray
    Feb 8, 2021 at 17:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.