1

When booting my lenovo laptop, all I see is:

Loading Linux 5.4.0-65-generic ...
Loading initial ramdisk ...

And then in hangs there forever.

I used to be able to go into the GRUB menu and select elementary, with Linux 5.4.0-40-generic and that would boot elementaryOS 5.1 successfully. But that option has now gone away in the GRUB menu. I believe what happened is at some point I ran apt autoremove, which uninstalled that older linux kernel.

My question is how do I reinstall the older linux kernel (5.4.0-40-generic) or how do I figure out why the newer linux kernel (5.4.0-65-generic) isn't working.

Edit:

Since I originally posted this, I have new information. I reinstalled elementary OS from a live USB and I found that will update the kernel to 5.4.0-65-generic and that boots just fine. I thought I had solved my problem, but then I ran apt update and apt upgrade and now my computer doesn't boot again. So I believe that sometime in the past month, one or multiple of those packages being upgraded is messing up the boot process on my laptop.

I reinstalled again, but this time only ran apt update and here is what I get when I run apt list --upgradeable: https://paste.ubuntu.com/p/WwXHdkYkBx/

4
  • Grub > advanced > recovery mode -- does that work to get you in at least?
    – KGIII
    Feb 3 at 20:52
  • Yeah, that boots into the recovery mode and that's how I've been able to back up my data Feb 4 at 6:31
  • You can install another kernel or you can try to fix it so that the current kernel boots. What happens when it doesn't boot normally?
    – KGIII
    Feb 4 at 10:04
  • I added new information related to my problem in the post, I am working on getting the list of upgraded packages posted. Feb 4 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.