0

I've been using elementary OS for a year now and haven't had problems previously. One day, however, I rebooted and found the system was dysfunctional in many parts but some parts still working, and being a noob I can't figure out where to start debugging.

Symptoms:

  • wifi finds networks and tries to connect, but stuck in "wi-fi connecting".
  • trying to open some applications fail(e.g. Firefox, Spotify, VSCode) in the sense that the application doesn't open but checking with htop (which I'm able to do) the processes seem to be there.
  • opening some other applications work (e.g. the system's graphical file explorer, calculator, Epiphany, and interestingly, Thunderbird [which is not installed with the system iirc])
  • With terminal, I'm able to navigate the filesystem, use top/htop (as mentioned), use neofetch (image below), but e.g. issuing a command sudo reboot will leave the process running, and ctrl+C doesn't have an effect.

enter image description here

I tried to use Gnome instead of Pantheon (as seen in the neofetch output) but I saw no difference. My question is, what are some possible approaches for debugging this problem?

0

Try to disable onboard gpu(intel) from bios looks like you're using GPU card, then try to update the Nvidia driver if there any update. And always you can start looking at logs.

0

All the problems were after all caused by the wifi chipset (Mediatek MT7630e), whose driver wasn't updated for >5.4.0-54 kernel releases. I noticed this when I booted to an older kernel and everything worked fine. Found a one-to-one fix from here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.