1

I'm new to linux, i'm trying to install Elementary OS on my Mac Pro, I get the 'elementary os' boot screen and the count down from 10 seconds but when I allow the operation to boot - it just goes to a black screen resulting in me restarting or shutting down the system.

I've also tried booting using 'f10' which yielded the same result.

Can I boot elementary using the command line?

Any thoughts or suggestions would be greatly appreciated! Apologies if this has been asked before.

EDIT: so I tried the following thank you for the suggestions but again im not sure if i've done something wrongenter image description here

Steve

1
  • Add nomodeset to grub. Press F10 during boot, hit the alt button, and add 'nomodeset' and see if that gets you a screen you can see.
    – KGIII
    Jan 2 at 20:00
1

Try to add "noefi" after "splash" at the end of the line. And you need to use a pc keyboard to press f10 otherwise it wont work. God luck.

0

The MacPro1,1 uses a 32-bit EFI which appears to be where the problems come in. A great resource is this post on mattgradient.com. If you're able to burn a DVD there is a prebuilt elementary OS 5.1 Hera image available. I can't attest to whether you should trust the ISO images from the site or not, but instructions for modding existing ISO's yourself are provided.

You might also find this Debian Wiki page for installing on the MacPro1,1 useful though it is a bit sparse.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.