0

Disclaimer: Newbie to Linux!

Recently installed Elementary OS as my main driver (not dual) booting for my Dell Inspiron laptop.

Issue:

System freezes randomly. Sometimes the freeze is just the display with sound and mouse/ keyboard working and sometimes it's a whole system freeze (display still on but frozen) and sometimes it starts with a display freeze then turns into a whole system freeze.

No clue where this is coming from. Happy to share more system info/ dumps info if needed.

Why I am posting this:

I do not want to revert back to Windows to be frank and most of the fixes I have seen have been for Nvidia GPU issues. Also the one thread I found not (Nvidia GPU) was never resolved and is three years old.

System Info:

description: Notebook
    product: Inspiron 7375 (0884)
    vendor: Dell Inc.
    version: 1.5.0
    serial: 39GD8L2
    width: 64 bits
    capabilities: smbios-3.1 dmi-3.1 smp vsyscall32
    configuration: boot=normal chassis=notebook family=Inspiron sku=0884 uuid=44454C4C-3900-1047-8044-B3C04F384C32
  *-core
       description: Motherboard
       product: 0GTNWX
       vendor: Dell Inc.
       physical id: 0
       version: A00
       serial: .39GD8L2.CNWSC0084900ZK.
       slot: Type2 - Board Chassis Location
     *-firmware
          description: BIOS
          vendor: Dell Inc.
          physical id: 0
          version: 1.5.0
          date: 07/09/2018
          size: 128KiB
          capacity: 8128KiB
          capabilities: pci pnp upgrade shadowing cdboot bootselect edd int13floppynec int13floppytoshiba int13floppy360 int13floppy1200 int13floppy720 int13floppy2880 int9keyboard int10video acpi usb smartbattery biosbootspecification netboot uefi
     *-cpu
          description: CPU
          product: AMD Ryzen 7 2700U with Radeon Vega Mobile Gfx
          vendor: Advanced Micro Devices [AMD]
          physical id: 4
          bus info: cpu@0
          version: AMD Ryzen 7 2700U with Radeon Vega Mobile Gfx
          serial: Unknown
          slot: FP5
          size: 1381MHz
          capacity: 3800MHz
          width: 64 bits
          clock: 100MHz
          capabilities: x86-64 fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp constant_tsc rep_good nopl nonstop_tsc cpuid extd_apicid aperfmperf pni pclmulqdq monitor ssse3 fma cx16 sse4_1 sse4_2 movbe popcnt aes xsave avx f16c rdrand lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw skinit wdt tce topoext perfctr_core perfctr_nb bpext perfctr_llc mwaitx cpb hw_pstate sme ssbd sev ibpb vmmcall fsgsbase bmi1 avx2 smep bmi2 rdseed adx smap clflushopt sha_ni xsaveopt xsavec xgetbv1 xsaves clzero irperf xsaveerptr arat npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold avic v_vmsave_vmload vgif overflow_recov succor smca cpufreq
          configuration: cores=4 enabledcores=4 threads=8

Dmesg dump:

Update: after using the GUI instead (And going through yet another crash). I have recovered a critical Kernel failure that popped up a couple times and then once before the crash:

[  962.010430] [UFW BLOCK] IN=wlp1s0 OUT= MAC=01:00:5e:00:00:01:48:5d:36:12:ea:21:08:00 SRC=192.168.1.1 DST=224.0.0.1 LEN=36 TOS=0x00 PREC=0xC0 TTL=1 ID=8221 DF PROTO=2 
7
  • I'd start checking the logs. Personally, I use a handy GUI app called ksystemlog and then I can see the actual errors and use those terms to search for solutions - or ask for more help but with detailed information regarding the crashes. – KGIII Dec 30 '20 at 20:32
  • I will use it and update with what it shows me if I cannot figure it out myself. Thank you for the advice!!!!! – Alex Dec 30 '20 at 20:56
  • added an update with something I found. Hope it helps with figuring out what is happening. Thanks @KGII – Alex Dec 31 '20 at 0:25
  • That's your firewall blocking something. I doubt that's the cause of the freeze. Going through your error messages and doing some searching, you might try adding pcie_aspm=off next to 'quiet_splash' in grub (between the quotes and with a space between them) and be sure to run 'sudo update-grub' when you're done - and then reboot. If that doesn't work, maybe someone else will come along with some ideas - I've never personally had this problem. – KGIII Dec 31 '20 at 0:52
  • 1
    oh! I will try that out for sure. Better safe than sorry. Also thanks for letting me know that's my firewall! I will dig to see if I can find anything else. Thank you so much again!!! – Alex Dec 31 '20 at 18:26
0

Looks like Nvidia driver issues happened a lot with me in past, I would start with GPU logs, Also can you please provide GPU info?, When you google just use ubuntu instead eOS that way you'll get more info.

Nvidia is tricky some times they say they don't have a solution for a certain model I had an issue with gtx 1080 ti GPU where Nvidia said they don't have a proper fix for ubuntu, I used an open-source driver instead of proprietary and that fixed my issue with gtx 1080 ti. you can give it a try.

0

Look, my answer i'snt probably gonna take your question in consideration just your problem. Sorry about that, but I think will help you.

I also have a Ryzen 7 (4800h) laptop (Lenovo Legion 5 15ARH05H) (I'm currently writing in it) and had the same issues (I even tried a few distros and a lot of them worked well but had a newer kernel).

The HWE kernel was loaded and running so no more solution from the system, then I thought that I needed a newer version and I use to use the mainline app to install newer versions. Here's a few steps of what I did

  • First, boot and press ESC or SHIFT to get menu

    • Select the elementary entry and press E, look for the linux line and at the end add a space and the number 3

    • then press F10 to boot into elementary but into text mode

  • login into the system

  • execute: sudo apt update

  • install : sudo apt install git

  • create a working directory named git in your home and enter into it: cd && mkdir git && cd git

  • execute: git clone git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git

  • enter into the directory: cd linux-firmware/amdgpu/

  • copy missing raven (renoir in my case, raven I believe is yours) libs: sudo cp raven* /lib/firmware/amdgpu/

    • you probably have some others missing like rtl_nic, copy them if you want but at the moment are not necessary and you can do it later
  • install software-properties-common: sudo apt install software-properties-common

  • install this ppa and the mainline package:

sudo add-apt-repository ppa:cappelikan/ppa
sudo apt update
sudo apt install mainline
  • Now install the I'm using, I haven't tried another one (at that moment I just picked the newest 5.9 because I remembered I read something in another distro's forum about that branch that was solved) and with the latest I got a lot of warnings and I didn't want to try it yet
sudo mainline --install 5.9.16
  • Install the drivers: sudo apt install xserver-xorg-input-synaptics-hwe-18.04

  • Reboot

If you have an Nvidia GPU continue with the next steps, if not then just use the system normally

  • Again, boot and press ESC or SHIFT to get grub menu

    • Select the elementary entry and press E, look for the linux line and at the end add a space and the number 3

    • then press F10 to boot into elementary but into text mode

  • login into the system

  • Install drivers: sudo apt install nvidia-driver-460

  • just in case run: sudo update-initramfs -u

  • Reboot and boot normally


Hope it helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.