0

I have USB HDD connected to ZTE internet router. HDD is shared on my home network over Samba share (SMB1) and accessible on two Windows machines and android box with rw permissions, those shares are functioning without problems.

I have recently installed eOS Hera 5.1.7 on my Lenovo Yoga 530 laptop and managed to succeed to mount HDD over samba share in my eOS. I can read the content of all directories on the disc but I can't open any of the files.

For past few days I have tried almost all possible combinations of parameters to get the permission to open files, but without success.

Current situation:

  • my router shares files over the network with SMB1 protocol and authorization with user, i.e. user1 and password user1 (I have checked workgroup => WORKGROUP)

  • I have installed cifs.utils on my eOS system and with following entry in /etc/fstab mounted shared HDD on my system:

//10.0.0.128/samba /mnt/share cifs vers=1.0,credentials=/home/useroneos/.smbcredentials,iocharset=utf8,gid=1000,uid=1000,file_mode=0777,dir_mode=0777,sec=ntlm 0 0
  • content of my .smbcredentials file is following:
username=user1
password=user1
workgroup=WORKGROUP

As I already wrote, I tested this entry in combination with many other parameters like rw, defaults, noperm, other sec versions, other SMB versions, but no luck. Also, I have tried to change file and directory permission for the whole /mnt path but without success. I have installed also sambaclient on eOS but, as I know, sambaclient or its configuration doesn't have influence on cifs functionality.

I have tried to open *.txt or *.pdf files over Files and Double Commander applications in Code and Document Viewer applications, also, with nano in terminal, but all of them returning same message: error reading file /mnt/share/.../xxx.txt: Permission denied.

I hope someone could help me.

Thanks in advance!

Best regards,

Tomislav

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.