1

I installed this little math program called NaSC. When I want to "Open sheets", the app just crashes. Nobody else seems to have this problem when using NaSC - at least, nobody seems to have filed any bug reports for it on Launchpad.

So I guess the problem is on the elementary OS side of things?

The error I get from the Terminal is:

I/O warning : failed to load external entity "/home/paul/.qalculate/definitions/datasets/elements.xml"
Speicherzugriffsfehler (Speicherabzug geschrieben)

So my noob-guess was, I'd just create that file in this folder. No luck. Any ideas?

System is up-to-date elementary OS Freya 0.3.1 64bit

4
  • Hey, strange. The mentioned file is not the problem. Can you run it from terminal with: nasc --debug and post the output. – Djax Oct 20 '15 at 20:00
  • First guess. You started nasc with root rights on the first run and now it can't read the file. ~/.local/share/nasc/nasc.sheets Try to delete it and start it again – Djax Oct 20 '15 at 20:05
  • Hm, I think I "kinda-solved" it. I deleted all the content of "My first sheet" and after that, I could create new sheets without crashing. But I still get the above-mentioned errormessages, sometimes with with a different file mentioned: planets.xml. Bottom line: works for me now - so far. – Paul Oct 20 '15 at 20:09
  • You should probably remove all files of NaSC first, then reinstall and make sure to not run NaSC as root again. – quassy Oct 22 '15 at 15:30
0

The problem is most likely the file ~/.local/share/nasc/nasc.sheets

Start NaSC again after you deleted this file.

Not the answer you're looking for? Browse other questions tagged or ask your own question.